PRB: Error Message: 0x80004005: General Error Unable to Open Registry Key (295297)



The information in this article applies to:

  • Microsoft Internet Information Services 5.0
  • Microsoft Internet Information Services version 6.0

This article was previously published under Q295297

SYMPTOMS

When you access a page that connects to an Access database, you may receive the following error message in the browser:
Microsoft OLE DB Provider for ODBC Drivers (0x80004005)[Microsoft][ODBC Microsoft Access Driver]General error Unable to open registry key 'Temporary (volatile) Jet DSN for process 0x614 Thread 0x6c0 DBC 0x21dd07c Jet'.
(FileName), (LineNumber)

CAUSE

The account that is being used to access the page does not have access to the HKEY_LOCAL_MACHINE\SOFTWARE\ODBC registry key.

RESOLUTION

IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry


WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

  1. Start Registry Editor (Regedt32.exe).
  2. Select the following key in the registry:

    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC

  3. On the Security menu, click Permissions.
  4. Type the required permissions for the account that is accessing the Web page.
  5. Quit Registry Editor.

STATUS

This behavior is by design.

Modification Type:MajorLast Reviewed:8/11/2006
Keywords:kbprb KB295297