PRB: Monitors Not Detected Correctly (295296)
The information in this article applies to:
- Microsoft Windows 2000 Driver Development Kit (DDK), when used with:
- the operating system: Microsoft Windows 2000
This article was previously published under Q295296 SYMPTOMS
Monitors are not detected correctly after the installation of video drivers when the monitor does not have an Inbox INF file.
CAUSE
This is a known issue in Microsoft Windows 2000. When there is no Inbox INF file present for the monitors during the installation of the video drivers, the monitors are reported to have a problem in the Device Manager with Code 28. This problem occurs because the Setup engine installs a NULL driver for the monitors when it does not find an INF file. Ideally, the Setup program should use the compatible ID for the monitors and install them correctly.
RESOLUTION
To work around this problem in Microsoft Windows 2000 either: - Update the monitor driver from the Device Manager Property page.
-or- - Update the monitor driver programmatically by using the UpdateDriverForPlugAndPlayDevices API. For more information about using the API, refer to the Microsoft Windows 2000 Device Driver Kit (DDK) documentation.
REFERENCES
Windows 2000 DDK Documentation
Modification Type: | Minor | Last Reviewed: | 7/27/2004 |
---|
Keywords: | kbdisplay kbPlugPlay kbprb KB295296 |
---|
|