BUG: ActiveSync Reports Unresolved Items When Device Resources Are Low (295001)



The information in this article applies to:

  • Microsoft Windows CE 3.0 for the Handheld PC
  • Microsoft Windows CE 2.11 for the Handheld PC
  • Microsoft Windows CE for the Palm-size PC, Versions 2.11
  • Microsoft Windows CE for the Pocket PC

This article was previously published under Q295001

SYMPTOMS

When you try to synchronize but have low device resources, ActiveSync may create a zero-length version of the file and report unresolved items.

CAUSE

A zero-length file may be created or an original file may be erased when the synchronization starts but is unable to finish because of insufficient resources. The process does not handle a synchronization failure correctly or display a meaningful error message.

RESOLUTION

To resolve this problem, free up resources on the device, and then try to resynchronize. You can free resources by deleting files and closing programs. You can also adjust the division of memory between file storage and programs by using the Memory utility in Control Panel.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

When ActiveSync reports an unresolved item, immediate backup of the desktop file is recommended. This is because the desktop file can be overwritten with the zero-length file from the device on subsequent file synchronization attempts.

Modification Type:MajorLast Reviewed:4/14/2004
Keywords:kbbug KB295001