SBS 4.5 Exchange 5.5 Setup on SBS 2000 Does Not Succeed with Error "0xc002041d" (294881)
The information in this article applies to:
- Microsoft Small Business Server 2000
This article was previously published under Q294881 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
While you attempt to install the Microsoft Exchange Server 5.5 from Microsoft Small Business Server (SBS) 4.5 on an SBS 2000 installation for Exchange Disaster Recovery purposes, or when it is necessary to recover a user's mailbox from an Exchange 5.5 Information Store, you may receive the following error messages:
While attempting to start the Microsoft Exchange Information Store service, the following error was encountered:
The service did not respond to the start or control request in a timely fashion.
Microsoft Windows NT
ID no: 0xc002041d
After the first error message, you receive the following error message:
The service did not respond to the start or control request in a timely fashion.
Microsoft Windows NT
ID no: 0xc002041d
The following two error messages are logged in the Event Viewer Application log:
Source: MSExchangeIS
Event ID: 1005
Type: Error
Description:
Unable to start the Microsoft Exchange Information Store. Error 0x7f.
Source: MSExchangeIS
Event ID: 5000
Type: Error
Description:
Unable to initialize the Microsoft Exchange Information Store service. Error 0x80004005.
The System Log of Event Viewer will report the following error:
Source: Service Control Manager
Event ID: 7024
Type: Error
Description:
The Microsoft Exchange Information Store service terminated with service specific error 2147500037.
CAUSE
This error message appears because the SBS 4.5 Exchange 5.5 Setup requires an application compatibility (appcompat) dynamic link library (DLL) to install properly on SBS 2000. In most cases, this information is already present in the registry and so the appcompat DLL is also present. If so, the error messages and attendant problems are not a factor, therefore, additional steps are not necessary to set up SBS 4.5 Exchange 5.5 Server on the SBS 2000 server. If this is not the case, you need to manually copy the necessary file from the CD-ROM, and then add the necessary information into the registry as described in the "Resolution" section of this article.
RESOLUTIONWARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk.
To make sure that SBS 4.5 Exchange 5.5 Server can install on SBS 2000:
- Verify that you have completely removed Exchange 5.5 by using the steps that are outlined in the following Microsoft Knowledge Base article, and then restart the computer if necessary:
259158 XADM: How to Manually Remove Exchange Server 5.5 Completely
- Copy the following text, paste it in Notepad, and then save the file as store.reg:
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\AppCompatibility\store.exe]
"DllPatch-SBSUpgrade"="_sbsw2ku.dll"
"SBSUpgrade"=hex:0c,00,00,00,00,00,00,00,03,00,00,00,0d,00,00,00,08,00,00,00,\
35,00,2e,00,35,00,00,00,0e,00,00,00,26,00,00,00,4d,00,69,00,63,00,72,00,6f,\
00,73,00,6f,00,66,00,74,00,20,00,45,00,78,00,63,00,68,00,61,00,6e,00,67,00,\
65,00,00,00,0f,00,00,00,14,00,00,00,45,00,4d,00,53,00,20,00,53,00,74,00,6f,\
00,72,00,65,00,00,00,00,00,00,00
- Locate the Store.reg file in Windows Explorer, and then double-click it to enter the value into the registry.
- Insert CD-ROM 1 of the SBS 2000 CD-ROM set into your CDROM drive. Copy the \i386\_sbsw2ku.dll file from the CD-ROM to your %SystemRoot%\AppPatch folder.
- Restart the SBS 4.5 Exchange Server 5.5 Setup.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Minor | Last Reviewed: | 1/18/2006 |
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Keywords: | kbHotfixServer kbQFE kberrmsg kbprb kbsetup KB294881 |
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