XCON: Empty Queues in SMTP Lead to Long Reset Route Times (294845)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q294845

SYMPTOMS

Mail delivery may be slow, and CPU use for Inetinfo.exe may be high. If you restart the Exchange 2000 services, the problem is alleviated.

CAUSE

This issue can occur if Exchange 2000 does not reset the empty Simple Mail Transfer Protocol (SMTP) queue correctly. Even though these queues are marked as empty, the queues are not in the empty list. As a result, garbage collection does not clean up these queues until the services are shut down. Because of this, a large number of empty list "reset routes" occur at a high rate, which impacts the performance of SMTP.

RESOLUTION

To resolve this problem, obtain the latest service pack for Microsoft Exchange 2000 Server. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

301378 XGEN: How to Obtain the Latest Exchange 2000 Server Service Pack

The English version of this fix should have the following file attributes or later:

Component: SMTP

File nameVersion
Reapi.dll6.0.4418.87
Resvc.dll6.0.4418.87
Phatq.dll6.0.4418.87
Tranmsg.dll6.0.4418.87
Mtaroute.dll6.0.4418.87

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server. This problem was first corrected in Microsoft Exchange 2000 Server Service Pack 1.

Modification Type:MinorLast Reviewed:6/5/2003
Keywords:kbbug kbExchange2000preSP1fix kbfix kbQFE KB294845