Incorrect password error when opening an Excel 2002 workbook by using Excel 97 or in Excel 2000 (294414)



The information in this article applies to:

  • Microsoft Excel 2002
  • Microsoft Excel 2000
  • Microsoft Excel 97 for Windows

This article was previously published under Q294414

SYMPTOMS

In Microsoft Excel 2000 or Microsoft Excel 97, if you attempt to open a Microsoft Excel 2002 workbook that is password-protected, Excel does not open the workbook when you supply the correct password, and you receive the following error message:
The password you supplied is not correct. Verify that the CAPS LOCK key is off and be sure to use the correct capitalization.

CAUSE

This behavior occurs if the workbook is saved in Excel 2002 under one of the following encryption schemes:
  • RC4, Microsoft Base Cryptographic Provider v1.0
  • RC4, Microsoft Base DSS and Diffie-Hellman Cryptographic Provider
  • RC4, Microsoft DH SChannel Cryptographic Provider
  • RC4, Microsoft Enhanced Cryptographic Provider v1.0
  • RC4, Microsoft Enhanced DSS and Diffie-Hellman Cryptographic Provider
  • RC4, Microsoft Enhanced RSA and AES Cryptographic Provider (Prototype)
  • RC4, Microsoft RSA SChannel Cryptographic Provider
  • RC4, Microsoft Strong Cryptographic Provider v1.0

RESOLUTION

To resolve this issue, open the workbook in Microsoft Excel 2002 and save the workbook under an encryption scheme that Microsoft Excel 2000 or Microsoft Excel 97 recognizes. To do this, follow these steps:
  1. Open the workbook in Microsoft Excel 2002.
  2. On the File menu, click Save As.
  3. In the Save As dialog box, click General Options on the Tools menu.
  4. In the Save Options dialog box, click Advanced.
  5. In the Encryption Type dialog box, click either Weak Encryption (XOR) or Office 97/2000 Compatible.
  6. Click OK in the Encryption Type dialog box, and then click OK in the Save Options dialog box.
  7. Click Save.

Modification Type:MinorLast Reviewed:1/6/2006
Keywords:kberrmsg kbprb KB294414