Error "No LU in LU Group Free" occurs when starting 3270 applet (294393)



The information in this article applies to:

  • Microsoft Host Integration Server 2004
  • Microsoft Host Integration Server 2000
  • Microsoft SNA Server 3.0 SP2
  • Microsoft SNA Server 3.0 SP3
  • Microsoft SNA Server 3.0 SP4
  • Microsoft SNA Server 4.0
  • Microsoft SNA Server 4.0 SP1
  • Microsoft SNA Server 4.0 SP2
  • Microsoft SNA Server 4.0 SP3
  • Microsoft SNA Server 4.0 SP4

This article was previously published under Q294393

SYMPTOMS

When the 3270 client is started, the error message "No LU in LU Group Free" appears.

CAUSE

In this case, SNA Server/Host Integration Server is working as designed. The error is caused by the application's Associated Printer LU (logical unit) feature. All display LUs are associated with a corresponding printer LU. Because all of the printer LUs are connected successfully to printer sessions, the associated LU feature blocks the connection to the associated display LU, and the "No LU in LU Group Free" message is returned.

NOTE: This error message may also appear if there are no LUs available, which is an unrelated issue.

RESOLUTION

To resolve the problem, disassociate the printer LUs from the display LUs and save the Com.cfg file.

MORE INFORMATION

Beginning with SNA Server 3.0 Service Pack 2 (SP2), the SNA Server does not allow a user to open a 3270 display LU if its associated printer is in use by another user. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

172637 User able to open Display session if associated printer in use

Users who have host applications with direct relationships between display LUs and printer LUs can associate printers with the display LUs. The associated printer feature, however, was designed for 3270 print emulators only and not for SNA Server print service sessions.

For additional information, see the following:

Chapter 3 of the Administration Guide. The Administration Guide is included with the Software Development Kit (SDK), which you must select to install during setup.

172637 User able to open Display session if associated printer in use

195063 Common user id problem when using associated printer feature


Modification Type:MajorLast Reviewed:5/23/2005
Keywords:KB294393