Denial-of-Service Attack with SFU 2.0 (294380)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows Services for UNIX 2.0

This article was previously published under Q294380

SYMPTOMS

The following Denial-of-Service vulnerabilities were discovered in Services for UNIX (SFU) 2.0:
  • Certain activities that are run against Port Mapper can cause Port Mapper to cause a blue-screen "Stop" error, or may cause a memory leak.
  • Using Telnet to access port 2049 (the NFS Server port) could cause a blue-screen "Stop" error.

CAUSE

The problem is caused by a logic error in the SFU implementation of the Sun RPC protocol.

RESOLUTION

Windows 2000

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that you determine are at risk of attack. Evaluate the computer's physical accessibility, network and Internet connectivity, and other factors to determine the degree of risk to the computer. See the associated Microsoft Security Bulletin to help determine the degree of risk. This hotfix may receive additional testing. If the computer is sufficiently at risk, we recommend that you apply this hotfix now.

To resolve this problem immediately, download the hotfix by following the instructions later in this article or contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled, if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The following file is available for download from the Microsoft Download Center:
Release Date: July 24, 2001

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

The English version of this fix should have the following file attributes or later:
   Date         Time  Version        Size    File name 
   ----------------------------------------------------
   31-Mar-2001  1957  5.2000.328.14  36,800  Rpcxdr.sys
				
NOTE: Due to file dependencies, this update requires Windows 2000 Service Pack 1 (SP1) or later.

Windows NT 4.0

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that you determine are at risk of attack. Evaluate your computer's physical accessibility, network and Internet connectivity, and other factors to determine the degree of risk to your computer. See the associated Microsoft Security Bulletin to help determine the degree of risk. This fix may receive additional testing. If your computer is sufficiently at risk, Microsoft recommends that you apply this fix now.

To resolve this problem immediately, download the fix by clicking the download link later in this article or contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, please visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled, if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The following file is available for download from the Microsoft Download Center:
Release Date: July 24, 2001

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

The English version of this fix should have the following file attributes or later:
   Date         Time  Version        Size    File name 
   ----------------------------------------------------
   31-Mar-2001  0757  5.2000.328.14  36,800  Rpcxdr.sys
				
NOTE: Due to file dependencies, this update requires Windows NT 4.0 Service Pack 6a (SP6a).

STATUS

Microsoft has confirmed that this problem may cause a degree of security vulnerability in Microsoft Services for Unix 2.0.

MORE INFORMATION

For more information on this vulnerability, see the following Microsoft Web site:

Modification Type:MajorLast Reviewed:10/21/2005
Keywords:kbHotfixServer kbQFE kbbug kbenv kbfix kbQFE KB294380