XFOR: Notes Calendar Connector Stops Responding on Multiprocessor Computers (294372)
The information in this article applies to:
- Microsoft Exchange 2000 Server
This article was previously published under Q294372 SYMPTOMS
The Exchange 2000 Server Notes Calendar Connector (Calcon) may stop responding on dual-processor computers. The crash dumps may show different stack traces and indicate heap corruption.
CAUSE
This problem can occur if a reference count check causes two threads to delete the same object at the same time.
RESOLUTIONTo resolve this problem, obtain the latest service pack for Microsoft Exchange 2000 Server. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
301378 XGEN: How to Obtain the Latest Exchange 2000 Server Service Pack
The English version of this fix should have the following file attributes or later:
Component: Notes Calendar Connector
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| Adminsvc.dll | 6.0.4672.00 | | Calcon.exe | 6.0.4672.00 | | Calsync.dll | 6.0.4672.00 | | Excalcon.exe | 6.0.4672.00 | | Gwisecal.dll | 6.0.4672.00 | | Gwrouter.exe | 6.0.4672.00 | | Mapical.dll | 6.0.4672.00 | | Notescal.dll | 6.0.4672.00 | | Profscal.dll | 6.0.4672.00 | | Rtdsmcal.dll | 6.0.4672.00 |
WORKAROUND
To work around this behavior, set the processor affinity on the Calcon.exe process to use one processor.
STATUSMicrosoft has confirmed that this is a problem in Microsoft Exchange 2000 Server. This problem was first corrected in Microsoft Exchange 2000 Server Service Pack 1.
| Modification Type: | Minor | Last Reviewed: | 6/5/2003 |
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| Keywords: | kbbug kbExchange2000preSP1fix kbfix kbQFE KB294372 |
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