XCCC: Error Message "Snap-In Failed to Initialize" (294211)



The information in this article applies to:

  • Microsoft Exchange 2000 Conferencing Server

This article was previously published under Q294211
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

If you install a third-party Conferencing Technology Provider (CTP) for which the associated Conferencing Manager snap-in file is either missing or unregistered, the CTP object (node) is removed from Conferencing Manager. Furthermore, if you later open a saved .msc file that contains the CTP snap-in file, you receive the following error message:
Snap-in failed to initialize.
Name - not available
CLSID: {GUID}
Typically, when you select an unregistered provider in Conferencing Manager, a stub node should appear in the Results pane.

CAUSE

The issue occurs when you create a CTP that is incompatible with the Windows 2000 Microsoft Management Console (MMC).

WORKAROUND

To work around this issue, use either of the following methods:

Method 1

Create your CTP by using Microsoft Visual Studio 7 or later.

Method 2

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
In Registry Editor, delete the value that is associated with the outside CTP in the following registry key:

HKEY_LOCAL_MACHINE\Software\Microsoft\MMC\NodeTypes\{ED01589D-0FD4-11d2-AC6B-00C04F991BCF}\Extension\Namespace


Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kberrmsg kbnofix kbprb KB294211 kbAudITPRO