Visio2002: Visio Is Not Installed When You Use Setup with /J Switch (294115)



The information in this article applies to:

  • Microsoft Visio 2002 Standard
  • Microsoft Visio 2002 Professional

This article was previously published under Q294115
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you use the /j switch to install Microsoft Visio Professional 2002, Visio is not installed and the Visio icon does not appear on the Start menu.

This occurs even though you receive the following message after you run the setup command:
Microsoft Visio Setup has completed successfully.

CAUSE

This issue can occur if the following conditions are true, and occur in the order listed:
  1. You install Visio Professional 2002 on the computer with a command line similar to the following:

    <path>\Setup /jm

  2. You install Visio Standard 2002 on the same computer with a similar command line.
  3. You start Visio Standard 2002 at least once.
  4. You remove Visio Standard 2002 from the computer by using the Add/Remove Programs tool in Control Panel.
  5. You install Visio Professional 2002 again on the computer using a similar command line.

RESOLUTION

To resolve this issue, use one of the following methods depending on your operating system.

Method 1: Microsoft Windows 2000

If you are using Windows 2000, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. In Control Panel, double-click Add/Remove Programs.
  3. Select Microsoft Visio Professional 2002, and then click Remove.
  4. Click Yes to completely remove Visio from your computer.
  5. Reinstall Visio Professional 2002.

Method 2: For Microsoft Windows 95, Microsoft Windows 98, or Microsoft Windows Millennium Edition

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

NOTE: If you do not want to edit the registry, you can also use Method 3 later in this article to directly install Visio on the computer that is using Windows 95, Windows 98, or Windows Millennium Edition.

If you are using Windows 95, Windows 98, or Windows Millennium Edition (Me), follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then click OK.
  3. In the Registry Editor, delete the following registry settings:
    HKEY_CURRENT_USER\Software\Microsoft\Installer\Products\9040150945D64D11EB3E000CF4993045
    HKEY_CURRENT_USER\Software\Microsoft\Installer\Features\9040150945D64D11EB3E000CF4993045
    					
  4. Reinstall Visio Professional 2002.

Method 3: For Any Version of Microsoft Windows

If you are using Microsoft Windows NT or any other version of Windows, you can directly install Visio Professional without using the /jm switch. For example, instead of using a command line similar to the following

<path>\Setup /jm

use a command line similar to the following:

<path>\Setup

NOTE: You may be advised that previous versions of Visio have been installed on your computer. If this occurs, select the option to Remove all previous versions (recommended), and then click Next.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about Setup command-line switches, click the article number below to view the article in the Microsoft Knowledge Base:

282119 Visio2002: Setup Command-Line Switches for Visio 2002


Modification Type:MinorLast Reviewed:7/27/2006
Keywords:kbbug kbpending KB294115