System Restore Does Not Restore Printer Drivers to Original State (293889)
The information in this article applies to:
- Microsoft Windows XP Home Edition
- Microsoft Windows XP Professional
This article was previously published under Q293889 SYMPTOMS
If you run System Restore to return to a checkpoint that you created before you installed your current, problematic printer driver, which has some files in common with a previously-installed printer driver, System Restore does not automatically roll back the driver to the previously installed driver.
CAUSE
This problem occurs because the architecture for printer drivers does not define exclusive file extensions that are used when you create printer drivers. Therefore, it is impossible to define a list of file extensions that exclusively represents printer drivers.
If you perform a search for Microsoft-provided printer driver file extensions, the results yield:
- .dll
- .drv
- .cfg
- .ini
- .dat
- .ntf
- .gpd
- .ppd
- .out
- .hlp
- additional files with no extensions
This list is not exhaustive. There are additional extensions that are in use by driver manufacturers, most of which represent binary information that the printer driver needs. Unfortunately, some of these extensions are also in use as data files, and there is no exclusive way to decipher them from those files.
RESOLUTION
To resolve this problem, open the printer properties, on the Advanced tab click the last driver that you installed from the Driver list, and then click OK to apply.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Minor | Last Reviewed: | 1/15/2006 |
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Keywords: | kbprb kbprint KB293889 |
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