The Computer Hangs with a Deadlock in Ndis.sys (293498)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 SP6a
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP6a
  • Microsoft Windows NT Workstation 4.0 SP6a

This article was previously published under Q293498

SYMPTOMS

Your computer may intermittently stop responding (hang).

CAUSE

This problem occurs because the driver does not restore the IRQ level when an error occurs.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date         Time   Version        Size     File name  Platform
   ---------------------------------------------------------------
   29-Mar-2001  05:23  4.0.1381.7095  121,872  Ndis.sys   x86
   29-Mar-2001  05:18  4.0.1381.7095  213,840  Ndis.sys   Alpha
				
NOTE: Because of file dependencies, this hotfix requires Microsoft Windows NT 4.0 Service Pack 6a.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/19/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE kbWinNT400nospFix KB293498