WD2002: Macros in Arabic and Hebrew Support.dot Template Do Not Run (293451)



The information in this article applies to:

  • Microsoft Word 2002

This article was previously published under Q293451

NOTE: This article discusses complex scripts functionality. Complex scripts functionality is available when you use the Office Language Settings tool to enable a language, such as Arabic or Hebrew, that requires this functionality. For more information about multilingual features, click Microsoft <I BRACKET="YES">your Office product</I> Help on the Help menu, type multilingual features in the Office Assistant or the Answer Wizard, and then click Search to view the topics that are returned.

SYMPTOMS

When you click one of the buttons in the Arabic or Hebrew version of the Word 2002 Support.dot template, nothing happens. The macros that are supposed to run do not run.

CAUSE

The names of the button controls do not match the names of the macros assigned to them.

WORKAROUND

To work around this problem, assign the correct names to the buttons:
  1. Open the Support.dot template. To do this, follow these steps:
    1. On the File menu, click Open.
    2. In the Files of type list, select Document Templates (*.dot).
    3. In the Look in box, select the following folder:

      C:\Program Files\Microsoft Office\Office10\Macros\

    4. Select the Support.dot file, and then click Open.
  2. On the View menu, point to Toolbars, and then click Control Toolbox.
  3. On the Control Toolbox command bar, click Design Mode.
  4. Right-click one of the buttons and then click Properties on the menu that appears.
  5. Change the (Name) property from "1" to the correct name shown in the following table:
       Button                   Correct Name
       -------------------------------------
       Troubleshoot Utility     Tshoot
       Registry Options         RegistryOpt
       Autocorrect Backup       acorrect
    					
  6. Repeat steps 4 and 5 to rename each of the buttons.
  7. On the Control Toolbox command bar, click Exit Design Mode.
  8. Save and close the Support.dot template.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about Support.dot, click the article number below to view the article in the Microsoft Knowledge Base:

289506 HOW TO: Install and Use the Support.dot Template


Modification Type:MinorLast Reviewed:7/27/2006
Keywords:kbbug kbnofix KB293451