"Unable to Contact All Domain Controllers" Error Message When Upgrading to SBS 2000 (293408)



The information in this article applies to:

  • Microsoft Small Business Server 2000

This article was previously published under Q293408

SYMPTOMS

When you attempt to upgrade a Microsoft Windows 2000-based server to Small Business Server (SBS) 2000 with Microsoft Windows NT 4.0-based backup domain controllers, you may receive the following error message:
Unable to contact all domain controllers.

CAUSE

This behavior occurs because Windows NT Server 4.0-based backup domain controllers must have Windows Management Instrumentation (WMI) installed to communicate during Setup.

RESOLUTION

To resolve this issue, download and install WMI for Windows NT 4.0 on the Windows NT 4.0-based backup domain controllers. You can download WMI from the following Microsoft Web site:

MORE INFORMATION

The error message that is listed in the "Symptoms" section of this article may also occur for the following reasons:
  • Additional domain controllers are listed in Active Directory but are no longer part of the domain.
  • Certain domain controllers may be temporarily unavailable.
To resolve these issues, either remove server objects from the Domain Controller container in Active Directory for domain controllers that are no longer present in the domain, or verify connectivity to all domain controllers.

For additional information, refer to the Small Business Server 2000 Updated Release Notes at the following Microsoft Web site:

Modification Type:MajorLast Reviewed:4/14/2006
Keywords:kberrmsg kbprb kbsetup KB293408