BUG: SQL Server Setup Causes Assertion Failures When BizTalk Server Is Installed on Cluster (293352)



The information in this article applies to:

  • Microsoft BizTalk Server 2000
  • Microsoft BizTalk Server 2000 SP1

This article was previously published under Q293352

SYMPTOMS

When you install Microsoft SQL Server 2000 on a Microsoft Windows 2000 clustered computer that already has BizTalk Server 2000 installed, you may receive the following error:
Microsoft Visual C++ Debug Library
Debug Assertion Failed!

Program: D:\WINNT\TEMP\_ISTMP1.DIR\_INS5576._MP
File: d:\bts\private\cis\common\sku\setupex\setupex.c
Line: 127

CAUSE

When you run the SQL Server Setup program on a clustered computer that already has BizTalk Server installed, two dialog boxes display assertion failures from BizTalk Server. The assertion failures occur because the SQL Server Setup program uses a DLL named Setupex.dll, which is also included in BizTalk Server. Because of this DLL naming conflict, SQL Server Setup incorrectly loads the BizTalk Server version of Setupex.dll, which causes the assertion failures.

RESOLUTION

Install SQL Server before you install BizTalk Server 2000. If this is not possible, rename the BizTalk Server version of Setupex.dll file before you run SQL Server Setup. To do this, perform the following steps:
  1. Open the Program Files\Microsoft BizTalk Server folder where BizTalk Server is installed.
  2. Rename the Setupex.dll file as Bts_setupex.dll.
  3. Run the SQL Server Setup program.
When the SQL Server Setup is complete, change the name of the BizTalk Server version of the Setupex.dll file back to its original name:
  1. Open the Program Files\Microsoft BizTalk Server folder where BizTalk Server is installed.
  2. Change the Bts_setupex.dll file to Setupex.dll.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:10/22/2003
Keywords:kbbug KB293352