SMS: Client Installation Is Not Successful and the "Client Deinstall Flag Set - No New Assignments Will Be Processed" Error Is Logged (293117)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0
  • Microsoft Systems Management Server 2.0 SP1
  • Microsoft Systems Management Server 2.0 SP2
  • Microsoft Systems Management Server 2.0 SP3

This article was previously published under Q293117

SYMPTOMS

New client installations are not successful when you use Logon Installation or Windows NT Remote Client installation. If you review the Wnmanual.log, Wn_logon.log, or Wn_remote.log in the %SystemRoot%\MS\SMS\Logs folder, the following error message is logged:
Client deinstall flag set - no new assignments will be processed.

CAUSE

This behavior occurs because the client computer has the following registry key value that prevents SMS from installing SMS Client components:

HKEY_LOCAL_MACHINE\Software\Microsoft\SMS\Client\Configuration\Client Properties\SMS Client Deinstall=True

WORKAROUND

To work around this behavior:
  1. Run the 20clicln.bat file to remove SMS Client components and registry keys.
  2. Run either the Smsman.exe or Smsls.bat program, or if you are using Windows NT Remote Client installation, allow any pending Client Configuration Requests (CCR) to retry. Pending requests are located in the \SMS\inboxes\ccrretry.box folder on the site server.

MORE INFORMATION

For additional information about methods to deinstall the client, click the article number below to view the article in the Microsoft Knowledge Base:

199078 SMS: How to Remove a Systems Management Server 2.0 Client


Modification Type:MinorLast Reviewed:1/14/2006
Keywords:kbClient kbConfig kberrmsg kbprb kbsetup kbUpgrade KB293117