Error message: STOP 0x000000EA THREAD_STUCK_IN_DEVICE_DRIVER (293078)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP 64-Bit Edition

This article was previously published under Q293078

SYMPTOMS

You may receive one of the following Stop error messages:
STOP 0x000000EA THREAD_STUCK_IN_DEVICE_DRIVER

STOP: 0x100000EA THREAD_STUCK_IN_DEVICE_DRIVER_M

CAUSE

This issue might occur if the display driver is caught in an infinite loop while it waits for the video hardware to become idle. This issue typically indicates a problem with the video hardware or that the display driver cannot program the hardware correctly.

RESOLUTION

To resolve this issue, obtain and install the most current driver for your video adapter, or replace your video card.

WORKAROUND

To work around this issue, follow these steps:
  1. Click Start, click Control Panel, and then double-click Display.
  2. On the Settings tab, click Advanced, and then click the Troubleshoot tab.
  3. Move the Hardware Acceleration slider to None, and then click to clear the Enable Write Combining check box.
  4. Click OK, and then click OK.

    Note This procedure prevents the display driver from programming the hardware incorrectly, but you may lose some display functionality and performance. Although you can increase the hardware acceleration settings higher than None to regain functionality and performance, these settings increase the chance that the issue will occur again. For maximum stability, leave hardware acceleration off.

MORE INFORMATION

The Stop error message may also occur in video adapter drivers that do not represent a physical device. For example, this Stop error message may occur in the virtual video adapter driver that is used by Symantec PCAnywhere. If PCAnywhere is installed on a computer where this error message occurs, visit the Symantec Web site to determine if there are any available fixes for your version of PCAnywhere.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:6/14/2006
Keywords:kbtshoot kbenv kberrmsg kbHardware kbprb KB293078