Problems Installing Internet Explorer 5.01 SP2 for Windows 2000 with Internet Explorer 5.5 (292810)



The information in this article applies to:

  • Microsoft Internet Explorer 5.01 for Windows 2000 SP 1
  • Microsoft Internet Explorer 5.01 for Windows 2000 SP 2

This article was previously published under Q292810

SYMPTOMS

The following symptoms may occur after you install Internet Explorer 5.01 Service Pack 2 (SP2) for Windows 2000, if Internet Explorer 5.5 or 5.5 Service Pack 1 (SP1) was already installed:
  • You may receive one of the following error messages when Setup finishes (before the computer restarts):
    Windows File Protection
    Files that are required for Windows to run properly have been replaced by unrecognized versions. To maintain system stability, Windows must restore the original versions of these files.
    Insert your Windows 2000 Server (or Professional) CD-ROM now.

    -or-

    Windows File Protection
    Files that are required for Windows to run properly have been replaced by unrecognized versions. To maintain system stability, Windows must restore the original versions of these files.
    The network location from which these files should be copied, \\server\share, is not available.
    Contact your system administrator or insert Windows 2000 Server (or Professional) CD-ROM now.
    If you either re-establish the network connection from which Windows 2000 was installed or insert your Windows 2000 CD-ROM and click Retry, Windows File Protection replaces your Microsoft Outlook Express files with the versions that are included with Windows 2000. If this occurs, you may also experience the following symptom.

    If you click Cancel, you receive the following error message:
    Windows File Protection
    You chose not to restore the original versions of the files. This may affect Windows stability. Are you sure you want to keep these unrecognized file versions?
    If you click Yes, the version number that is displayed for Outlook Express when you click About Outlook Express on the Help menu may be updated, and the following error message may be logged in the System event log (where file_name.ext is Msoert2.dll, Acctres.dll, Msoeacct.dll, Inetres.dll, Inetcomm.dll, Wab32.dll, Wab32res.dll, Directdb.dll, Wab.exe, Wabmig.exe, Wabfind.dll, Wabimp.dll, Oemiglib.dll, Oemig50.dll, Setup50.dll, Msimn.exe, Oeimport.dll, Msoe,dll, Msoeres.dll, Csapi3t1.dll, Scrrun.dll, Vbscript.dll, Sendmail.dll, Msxml.dll, Msrating.dll, Msieftp.dll, Msident.dll, Mshtmler.dll, Mshta.dll, Inseng.dll, Imgutil.dll, Iesetup.dll, Iepeers.dll, Iedkcs32.dll, Cdfview.dll, Asctrls.ocx, and Advpack.dll, x.xx.xxxx.xxxx represents various version numbers, and user_name is the user name of the administrator who clicked Cancel):
    Event ID: 64005
    Source: Windows File Protection
    Type: Information
    Description: The protected system file file_name.ext was not restored to its original, valid version because the Windows File Protection restoration process was cancelled by user interaction, user name is user_name. The file version of the bad file is x.xx.xxxx.xxxx.
    This behavior occurs if Windows File Protection does not replace your Outlook Express files with the version that was included with Windows 2000, but System File Checker replaces your Outlook Express files with the version that was included with Windows 2000 when you run System File Checker (for example, the Sfc /scannow command). If this occurs, you may also experience the following symptom.
  • The version number for Outlook Express that is displayed when you click About Outlook Express on the Help menu may remain unchanged, and following error message may be logged in the System event log (where file_name.ext is Msoert2.dll, Acctres.dll, Msoeacct.dll, Inetres.dll, Inetcomm.dll, Wab32.dll, Wab32res.dll, Directdb.dll, Wab.exe, Wabmig.exe, Wabfind.dll, Wabimp.dll, Oemiglib.dll, Oemig50.dll, Setup50.dll, Msimn.exe, Oeimport.dll, Msoe.dll, Msoeres.dll, Csapi3t1.dll, Scrrun.dll, Vbscript.dll, Sendmail.dll, Msxml.dll, Msrating.dll, Msieftp.dll, Msident.dll, Mshtmler.dll, Mshta.dll, Inseng.dll, Imgutil.dll, Iesetup.dll, Iepeers.dll, Iedkcs32.dll, Cdfview.dll, Asctrls.ocx, and Advpack.dll, and x.xx.xxxx.xxxx and y.yy.yyyy.yyyy are various version numbers):
    Event ID: 64001
    Source: Windows File Protection
    Type: Information
    Description: File replacement was attempted on the protected system file file_name.ext This file was restored to the original version to maintain system stability The file version of the bad file is x.xx.xxxx.xxxx, the version of the system file is y.yy.yyyy.yyyy.
    This behavior occurs if Windows File Protection restores your Outlook Express files to the version that was included with Windows 2000.

    If Internet Explorer 5.01 SP1 was installed before Internet Explorer 5.5 was installed, you may receive the following error message when you attempt to start Outlook Express:
    Outlook Express
    Outlook Express could not be started because MSOE.DLL could not be loaded.

CAUSE

This behavior occurs because Internet Explorer 5.01 SP2 incorrectly attempts to install some components, even if a later version of Internet Explorer is already installed.

RESOLUTION

To resolve this issue and update Outlook Express to the version that is included with Internet Explorer 5.01 SP2, uninstall Internet Explorer 5.5 or 5.5 SP1, reinstall Internet Explorer 5.01 SP2, and then reinstall Internet Explorer 5.5 SP1. For additional information about how to uninstall Internet Explorer 5.5 or 5.5 SP1, click the article number below to view the article in the Microsoft Knowledge Base:

257234 How to Uninstall Internet Explorer 5.5

MORE INFORMATION

The following Windows 200 and Internet Explorer versions include the following versions of Outlook Express:
  • Microsoft Windows 2000 includes Outlook Express version 5.00.2919.6700.
  • Windows 2000 Service Pack 1 (SP1) and Internet Explorer 5.01 SP1 for Windows 2000 include Outlook Express version 5.50.4133.2400.
  • Internet Explorer 5.01 SP2 for Windows 2000 includes Outlook Express version 5.50.4522.1200.
When you upgrade Windows 2000 to Internet Explorer version 5.5 or 5.5 SP1, Outlook Express is not upgraded. To upgrade Outlook Express to version 5.50.4133.2400 on Windows 2000, you must install Windows 2000 SP1 (or Internet Explorer 5.01 SP1). To upgrade Outlook Express to version 5.50.4522.1200 on Windows 2000, you must install Internet Explorer 5.01 SP2. For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

257238 OLEXP: Outlook Express 5.01 Not Upgraded on Windows 2000

222471 Description of the Windows 2000 System File Checker Tool


Modification Type:MajorLast Reviewed:9/22/2003
Keywords:kbinterop kbprb kbsetup KB292810