"Logical Assertion Has Failed" Error Message When You Install Windows (292763)



The information in this article applies to:

  • Microsoft Windows 95
  • Microsoft Windows 98
  • Microsoft Windows Millennium Edition

This article was previously published under Q292763
If this article does not describe your hardware-related issue, please see the following Microsoft Web site to view more articles about hardware:

SYMPTOMS

When you attempt to install Microsoft Windows 95, Microsoft Windows 98, or Microsoft Windows Millennium Edition (Me) on your computer, you may receive an error message similar to one of the following when Microsoft ScanDisk checks the computer drive before Setup starts:
Logical Assertion has Failed

Expression: IDXStart<M memlocks

Source: line 264 of msprintf:c
-or-
Logical Assertion Failed

Expression IDXStart <= nMem Blocks

Source: line 266

File msprintf.c
After you receive one of these error messages, you are unable to install Windows on the computer.

NOTE: You may also receive one of these error messages during Setup.

CAUSE

This behavior can occur because of a defective or incorrectly configured hard disk or related hardware component.

This behavior can also occur because of corrupted hard-disk drive overlay software.

RESOLUTION

To resolve this issue, quit Windows Setup and use the following check list to troubleshoot the source of the error message:
  • Check the physical connections to the hard disk. For example, check that all cables are properly oriented and connected.
  • Check all jumper settings on the hard disk.
  • Replace the ribbon cable on the hard disk.
  • Check the Basic Input Output System (BIOS) settings for the hard disk to verify the proper configuration.

    NOTE: For information about how to gain access to the computer BIOS, consult your computer's owners manual.
  • Test the hard disk controller and/or the hard disk itself. To do so, either use third-party testing software or temporarily replace the computer's motherboard.

    NOTE: The error message may be caused by a defective Integrated Drive Electronics (IDE) hard disk.
If all hardware settings appear to be correct, and your computer uses drive overlay software, there may be an issue with this software. Contact the manufacturer of the hard disk for information about troubleshooting the drive overlay software.

For information about how to contact your hard-disk manufacturer, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

If all of the preceding configuration settings appear to be correct, restart the computer by using a Windows Startup disk. At the command prompt, follow these steps:
  1. Type SCANDISK drive:, where drive is the letter of the drive that you want to scan, and then press ENTER.
  2. When ScanDisk finishes testing the drive, press ENTER to perform a surface scan on the hard disk.

MORE INFORMATION

For additional information about installing Windows, click the article numbers below to view the articles in the Microsoft Knowledge Base:

87239 Windows Err Msg: Fault in MS-DOS Extender

255867 How to Use the Fdisk Tool and the Format Tool to Partition or Repartition a Hard Disk


Modification Type:MajorLast Reviewed:8/8/2006
Keywords:kberrmsg kbprb KB292763