TechNet - Error "A system call on line 135 failed with error code 1608" (292747)



The information in this article applies to:

  • Microsoft TechNet

This article was previously published under Q292747

SYMPTOMS

When installing the TechNet Technical Information CD, you may get the following error:
A system call on line 135 failed with error code 1608

CAUSE

This error is caused by information in the registry from a previously installed version of the TechNet Technical Information CD that was missed by the installation process of the most recently installed Technical Information CD.

RESOLUTION

  1. Create an installation log.

    Create a Windows Installer log file to find the ID number of the previously installed TechNet CD that is causing the installation failure.
    1. Insert your newest TechNet Technical Information CD, then cancel any Auto run windows that appear.
    2. Click Start, then click Run.
    3. In the Command line, type

      msiexec /i X:\FILENAME.MSI /l*v C:\technet.log

      then click OK.Note:
      • "X" is the drive letter for your CD-ROM drive.
      • FILENAME.MSI is the name of the MSI file in the root directory of the CD-ROM
      • Example:

        For the February 2001 Technical Information CD in driver letter "D:\":
        msiexec /i d:\tn0102.msi /l*v C:\technet.log
    4. Continue through the installation as normal until the installation fails with the error message. This should create the "technet.log" file that will help you to resolve the issue.
  2. Create the Program ID from the installation log file.

    Next you will need to use the information in the log file to find the program ID number of the conflicting program.
    1. Open the "technet.log" file that should be located in the root of your C:\ drive. If a program is not associated with this .log file, use Notepad.
    2. Search the system for the term "DOOMED_PRODUCTS". You should find this information lines in the format in the example below.
      Property(C): DOOMED_PRODUCTS = {12345678-1234-1234-ABCD-EFGHIJKLMNOP}
    3. The number between the brackets in the log file is the what you'll need to determine the program ID to resolve the issue.
    4. You will create the program ID by following the steps below using the number that is found in your log file. The examples below each step should help to illustrate how this is done.
      1. Remove the dashes, then break the last two groups of letters into pairs:

        Before: 12345678-1234-1234-ABCD-EFGHIJKLMNOP
        After: 12345678 1234 1234 AB CD EF GH IJ KL MN OP
      2. Reverse the letters and numbers in each new group:

        Before: 12345678 1234 1234 AB CD EF GH IJ KL MN OP
        After: 87654321 4321 4321 BA DC FE HG JI LK NM PO
      3. Finally, combine each group into one large group by removing the spaces. You will use this program ID to search your registry:

        Before: 87654321 4321 4321 BA DC FE HG JI LK NM PO
        After: 8765432143214321BADCFEHGJILKNMPO
    5. Remove all occurrences of this Program ID from your registry.

      WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk and read the following information carefully.

      For information about how to edit the registry, view the "Changing Keys and Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete Information in the Registry" and "Edit Registry Data" Help topics in Regedt32.exe.

      Back up the registry before you edit it. If you are using Windows NT or Windows 2000, update your Emergency Repair Disk (ERD).

      1. To open Registry Editor, click Start, then click Run, and then type regedit in the Open box. Then click OK.
      2. To search for all occurrences of the Program ID, click Edit from the main menu and click Find.
      3. In the "Find what:" box, type the entire Program ID you obtained by using the steps above. Ensure all three of the Keys, Values, and Data boxes are checked, then click Find Next.
      4. You will need to delete all items with this Program ID that are found in your registry. When an item is found on the left pane (the directory pane) right-click the highlighted key and select Delete. When an item is found on the right pane (or contents pane), right-click the item's icon in the "Name" column and select Delete.
      5. Continue with the search by pressing the F3 key on your keyboard to find the next occurrence of the Program ID. Do this until the "Finished searching through the registry" dialog box is given.
      6. . Once all occurrences of this Program ID have been deleted, restart your PC. You should then be able to install the TechNet Technical Information CD without error.

MORE INFORMATION

The following Knowledge Base Article more clearly defines the switches used as part of the above resolution.

227091 Command-Line Switches for the Microsoft Windows Installer Tool


Modification Type:MajorLast Reviewed:6/6/2001
Keywords:kbprb KB292747