You receive an "Installation ended prematurely because of an error" error message when you remove, repair, re-install, or change features for your Office XP installation (292238)



The information in this article applies to:

  • the operating system: Microsoft Windows NT 4.0
  • the operating system: Microsoft Windows 2000
  • Microsoft Office XP Professional
  • Microsoft Office XP Small Business
  • Microsoft Office XP Standard
  • Microsoft Office XP Students and Teachers
  • Microsoft Office XP Developer
  • Microsoft Access 2002
  • Microsoft Excel 2002
  • Microsoft FrontPage 2002
  • Microsoft Outlook 2002
  • Microsoft PowerPoint 2002
  • Microsoft Word 2002

This article was previously published under Q292238
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to uninstall, repair, reinstall, or change features for your Office installation, you may receive the following error message:
Installation ended prematurely because of an error.
If you enable verbose logging for these operations, you may see text similar to the following in your log file:
RegisterProductID:  Unable to create HKEY_LOCAL_MACHINE\Software\Microsoft\Office\10.0\Registration\{90280409-6000-11D3-8CFE-0050048383C9}. Hence ProductID, PIDKEY,  & DigitalProductID keys will not be Registered
Action ended 13:16:04: InstallExecute. Return value 3.
				

CAUSE

This problem can occur if the permissions on the following registry key are incorrect:

HKEY_LOCAL_MACHINE\Software\Microsoft\Office

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.


To resolve this problem, follow these steps for the version of Microsoft Windows that is running on your computer.

Microsoft Windows NT 4.0

  1. Quit all Windows programs.
  2. On the Start menu, click Run.
  3. In the Open box, type Regedt32.exe and then click OK.
  4. Select the HKEY_LOCAL_MACHINE on Local Machine window.
  5. Locate and select the following key:

    \Software\Microsoft\Office

  6. On the Security menu, click Permissions.
  7. The following table lists the default registry permissions on this key.
     Name                            Permissions
     ----------------------------------------------
     Creator Owner                   Full Control
     Everyone                        Special Access
     <machine name>\Administrators   Full Control
     System                          Full Control
    						
    The permissions that you set for this key and its subkeys vary, according to your situation. At a minimum, change the permissions on the System account to Full Control, and to Read for the other accounts listed.

    NOTE: Make sure that you select the Replace permission on existing subkeys check box.
  8. Click OK in the Registry Permissions dialog box.
  9. Click Yes to confirm replacing permissions on existing subkeys.
  10. On the Registry menu, click Exit. You should now be able to uninstall, repair, reinstall, add, or change features in your Office installation.

Microsoft Windows 2000

  1. Quit all Windows programs.
  2. On the Start menu, click Run.
  3. In the Open box, type Regedt32.exe and then click OK.
  4. Select the HKEY_LOCAL_MACHINE on Local Machine window.
  5. Locate and select the following key:

    \Software\Microsoft\Office

  6. On the Security menu, click Permissions.
  7. The following table lists the default registry permissions on this key.
       Name                            Permissions
       ----------------------------------------------
       
       Administrators                  Full Control
       Creator Owner                   Full Control
       Power Users                     Special
       System                          Full Control
       Users                           Read
    						
    The permissions that you set for this key and its subkeys vary, according to your situation. At a minimum, change the permissions on the System account to Full Control, and to Read for the other accounts listed.
  8. In the Permissions for Office dialog box, clear the Allow Inheritable permissions from parent to propagate to this object check box.
  9. Select the System account, and then click the Full Control check box under Allow.
  10. In the Permissions for Office dialog box, click Advanced.
  11. For any object listed in the preceding table that does not have the Full Control permissions as stated in the table, you may also have to select the object, click View/Edit, and then verify the missing permissions.
  12. Select the Reset permissions on all child objects check box, and then clear the Allow Inheritable permissions from parent to propagate to this object check box.
  13. Click OK and then click Yes to the prompt to enable propagation of inheritable permissions.
  14. Click OK in the Registry Permissions dialog box.
  15. On the Registry menu, click Exit. You should now be able to uninstall, repair, reinstall, add, or change features in your Office installation.

Modification Type:MinorLast Reviewed:2/16/2006
Keywords:kbRegistry kbuninstall kbtshoot kbprb KB292238