Plug and Play Printer May Not Resume If an Updated Vcomm.vxd Driver Is Installed on Your Computer (291854)



The information in this article applies to:

  • Microsoft Windows 98 Second Edition

This article was previously published under Q291854

SYMPTOMS

Your Plug and Play printer may not resume from a dormant suspend state (D3) after the parallel (LPT) port is closed. This problem can occur if you have installed the Vcomm.vxd update that is mentioned in the following Microsoft Knowledge Base article:

242939 Legacy Parallel Devices May Not Respond After Resume

You may also not be able to access parallel ports that are attached to other devices, for example, scanners, external removable mass media drive, or external SCSI controllers.

CAUSE

This problem can occur because of the way that the power management function is handled when the port is opened and closed. If the port is closed, VCOMM places the LPT port and printer to a D3 state. After you open the port, the power state of the printer is incorrect even though the LPT port goes to D0 state.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English-language version of this fix should have the following file attributes or later:
   Date      Time    Version      Size    File name  Platform
   -----------------------------------------------------------------
   7/7/2000  6:43pm  4.10.0.2224  33,115  Vcomm.vxd  Windows 98
                                                      Second Edition
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

The update for this problem is posted to the Microsoft Support Web page. To obtain the updated fix, click the following link: For additional information about Windows 98 and Windows 98 Second Edition hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

206071 General Information About Windows 98 and Windows 98 Second Edition Hotfixes


Modification Type:MinorLast Reviewed:10/18/2005
Keywords:kbHotfixServer kbQFE kbdownload kbdownload kbDriver kbenv kbprb kbprint kbQFE KB291854