TIFF Filter Stops Working After You Start the Windows Components Wizard (291835)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001

This article was previously published under Q291835
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

After you start the Windows Components Wizard on a SharePoint Portal Server computer, the Tagged Image File Format (TIFF) Index Filter (IFilter) does not filter .tif and .tiff files. To access the Windows Components Wizard, click Start, click Control Panel, click Add/Remove Programs, and then click Add/Remove Windows components.

This issue occurs when you click any additional Windows component, and then click Next. This issue occurs even if you cancel out of the wizard and do not install the selected component.

NOTE: This issue only occurs if Windows 2000 Indexing Service is running on the computer.

CAUSE

The TIFF IFilter (Mspfilt.dll) that is installed by SharePoint Portal Server no longer filters .tif and .tiff files after the Windows 2000 Indexing Service null (default) IFilter is registered to handle those file extensions. The null IFilter only emits file system properties such as file name and last modified date; it does not emit the contents of the file.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue, move the registration for Mspfilt.dll to the end of the list that is maintained by Indexing Service:
  1. Start Registry Editor (Regedt32.exe).
  2. Locate the DLLsToRegister value under the following key in the registry:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\ContentIndex

  3. On the Edit menu, click Multi String, and then move the line that references Mspfilt.dll to the end of the list.
  4. Click OK, and then quit Registry Editor.
  5. Restart the Microsoft Search service.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Windows 2000 Indexing Service has its own set of IFilters. It does not have a TIFF IFilter. When SharePoint Portal Server is installed and the TIFF IFilter is enabled, it becomes the registered IFilter for .tiff files.

Indexing Service maintains a list of IFilter dynamic-link libraries (DLLs) to register. On a Windows 2000 installation that does not have SharePoint Portal Server installed, the null IFilter (Query.dll) is the registered IFilter for .tiff files. Each time you start Indexing Service, it looks at the list of DLLs in the DLLsToRegister registry value and registers each of the DLLs in order. When SharePoint Portal Server is installed, Mspfilt.dll is added to the end of this list so that Indexing Service can make use of the TIFF IFilter. Because Mspfilt.dll is registered after Query.dll, it is the file that is used for filtering .tiff files.

When you access the Windows Components Wizard, click a component, and then click Next, the Windows Components list is rebuilt, and the list of DLLs that are used by Indexing Service are rewritten to the DLLsToRegister value. Mspfilt.dll is then moved to the beginning of the list. Therefore, each time Indexing Service starts, it registers Query.dll for .tiff files.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbbug KB291835