Notes to Exchange Mail Flow Stops Functioning (291381)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • Microsoft Exchange Server 5.5
  • Microsoft Exchange Server 5.5 SP1
  • Microsoft Exchange Server 5.5 SP2
  • Microsoft Exchange Server 5.5 SP3
  • Microsoft Exchange Server 5.5 SP4

This article was previously published under Q291381

SYMPTOMS

Mail flow from Lotus Notes to a Microsoft Exchange server does not function correctly. The conversion process stops and you cannot restart it. The application of the Exchange 5.5 Server Service Pack 4 (SP4) temporarily resolves the behavior but then the Exchange Notes Connector service stops functioning. This process also applies to Exchange 2000. The following errors are logged in the Exchange connectivity browser logs:
2001/03/02 13:31:01- LME-NOTES-NTSMEX(014a) 4 54009:Processing outbound message from Notes. Sender: 'Firstname Lastname/Company@COMPANY' Note ID: 'UNID: OFC13E311A:A2A5C7D4-ON882569EC:001F0AC3'.
>> nts2mex(2621)

2001/03/02 13:31:01- LME-NOTES-NTSMEX(014a) 4 32036:Initializing new outbound Exchange message
>> mexhcs(1021)

2001/03/02 13:31:01- LME-NOTES-NTSMEX(014a) 4 32038:New outbound Exchange message initialized
>> mexhcs(1035)

2001/03/02 13:31:01- LME-NOTES-NTSMEX(014a) 4 32036:Initializing new outbound Exchange message
>> mexhcs(1021)

2001/03/02 13:31:01- LME-NOTES-NTSMEX(014a) 4 32038:New outbound Exchange message initialized
>> mexhcs(1035)

2001/03/02 13:31:02- LME-NOTES-NTSMEX(014a) 2 31200:Exchange Server has returned the condition: 80070057
>> mexint(218)

2001/03/02 13:31:02- LME-NOTES-NTSMEX(014a) 2 31201:Microsoft Package ID: Win 32
>> mexint(226)

2001/03/02 13:31:02- LME-NOTES-NTSMEX(014a) 2 31203:Extended NT information: The parameter is incorrect.
>> mexint(262)

2001/03/02 13:31:02- LME-NOTES-NTSMEX(014a) 2 31081:Cannot create custom Exchange address for user
>> mexe(14045)

2001/03/02 13:31:02- LME-NOTES-NTSMEX(014a) 2 31200:Exchange Server has returned the condition: 80070057
>> mexint(218)

2001/03/02 13:31:02- LME-NOTES-NTSMEX(014a) 2 31201:Microsoft Package ID: Win 32
>> mexint(226)

2001/03/02 13:31:02- LME-NOTES-NTSMEX(014a) 2 31203:Extended NT information: The parameter is incorrect.
>> mexint(262)

2001/03/02 13:31:02- LME-NOTES-NTSMEX(014a) 2 31081:Cannot create custom Exchange address for user
>> mexe(14045)

2001/03/02 13:31:02- LME-NOTES-NTSMEX(014a) 2 32055:Error committing Exchange message
>> nts2mex(2926)

2001/03/02 13:31:02- LME-NOTES-NTSMEX(014a) 2 00514:A RESTART request has been received
>> stdmain(934)

2001/03/02 13:31:02- LME-NOTES-NTSMEX(014a) 3 00505:LME-NOTES-NTSMEX is ending, last return code was {A shutdown request was made}
>> stdmain(958)
NOTE: In Exchange 5.5 the connectivity browser logs are located in the \Exchsrvr\Connect\Exchconn\Logs folder. In Exchange 2000 the logs are located in the \Exchsrvr\Conndata\Logs folder. Also note that to enable the logging you must first create the logs folder in Exchange 2000. For additional information on the Connectivity Browser Logs in Exchange 2000 and how to enable logging, click the article number below to view the article in the Microsoft Knowledge Base:

269040 How to Use Lsadmin.exe on Exchange 2000 Server

CAUSE

This behavior occurs when a message from Notes cannot be converted successfully by the LME-NOTES-NTSMEX process.

RESOLUTION

To resolve this behavior, locate the message that is causing the problem. Search the Exchange connectivity browser log for the last message that was processed prior to the time when the process stopped working:
  1. Perform a search for the number "54009" starting from bottom of the latest connectivity browser log.
  2. You should find the following entry:

    54009:Processing outbound message from Notes. Sender: 'Firstname Lastname/Company@COMPANY' Note ID: 'UNID: OFC13E311A:A2A5C7D4-ON882569EC:001F0AC3'

  3. After this entry, you should see the other errors listed, such as 31200, 31201, 31203 and 31081.
  4. This is the message that you need to be remove with the Notes client from Exchange server.
  5. To delete this message, open the Notes client, navigate to the Exchange.box folder, and then find and delete this message from the user found in the browser logs. If there is more than one, pick the oldest message that is listed.
  6. The conversion of Notes to Exchange process should recover automatically and mail flow should be restored.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbprb KB291381