OFFXPDEV: MODTBAD Errors When You Save a Template to File from a Client Computer (291032)



The information in this article applies to:

  • Microsoft Office XP Developer

This article was previously published under Q291032

SYMPTOMS

When you try to save a template to file by using the Save to File option from a workflow client computer, you receive the following error message:
Error trying to create template. DCOM server modTBAD failed to successfully complete the task.
In addition, the template is not saved to file; it remains in the modSystem database on the workflow server.

CAUSE

The Save to File option only works if the folder is on the same computer as the workflow server.

RESOLUTION

Use the Save to File option only from the workflow server computer and not from a workflow client computer.

This error message was corrected in Office XP Developer Service Pack 1 (SP-1) to let you know this option is only available on the same computer as the workflow server.

For additional information about how to obtain and install Office XP Developer SP-1, click the article number below to view the article in the Microsoft Knowledge Base:

313166 OFFXPDEV: How to Obtain and Install Office XP Developer Service Pack 1 (SP-1)

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This error message was corrected in Office XP Developer SP-1.

MORE INFORMATION

When you try to save a template to a file by using the Save to File option from a workflow client computer, after installing Office XP Developer SP-1, you receive the following message.

DCOM Server ModTBad Failure

Unable to save the template at the file location specified. The server process (ModTBad) does not have permission to write to this location. Save the template on the Workflow Server and use the Workflow Manager for SQL Server to export the template to the desired location.

The Save to File option is designed to be used on the same computer as the workflow server.

Steps to Reproduce the Behavior

  1. Install Microsoft Office XP Developer Workflow Services for SQL Server onto a Microsoft Windows 2000 Server-based computer.
  2. Install all necessary software to create a Workflow Services for SQL Server client computer on a Microsoft Windows 98-based computer.
  3. From the workflow server computer, create a workflow solution.
  4. From the Windows 98 workflow client computer, start modTplWiz (modTplWiz.exe).
  5. On the Select Implementation Options page, click to select the Save to File check box.
  6. Click Finish. Note that you receive the error message that is mentioned in the "Symptoms" section of this article. Note also that the template is not saved to the file, but that it remains in the workflow server modSystem database.

Modification Type:MajorLast Reviewed:2/12/2002
Keywords:kbbug kberrmsg KB291032