Error Messages Are Displayed When You Perform an In-Place Upgrade (290790)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional

This article was previously published under Q290790

SYMPTOMS

When you attempt to perform an in-place upgrade on Windows 2000 you may receive the following message at the start of the graphical user interface (GUI) Setup:
Please insert the compact disc labeled 'Windows 2000 (version) CD-ROM' into your CD-ROM Drive (x:), and then click OK.
When you click OK, you may receive the following message:
The file NT5inf.cat on the 'Windows 2000 (version) CD-ROM' is needed. Type the path where the file is located, and then click OK.
If you press CANCEL, you may receive the following error message:
Fatal Error: An error has been encountered that prevents Setup from continuing. Setup failed to install the product catalogs. This is a fatal error. The setup log files should contain more information. Click OK to view the Setup log file.

CAUSE

This behavior can occur if Adaptec DirectCD (any Windows 2000-compatible version) software has been run on the computer before you started the Windows 2000 in-place upgrade.

RESOLUTION

To work around this behavior, rename the Adaptec DirectCD driver, Cdudf.sys:
  1. Run Windows 2000 Setup and wait for the following message to be displayed:
    Please insert the compact disc labeled 'Windows 2000 (version) CD-ROM' into your CD-ROM Drive (x:), and then click OK.
  2. Press SHIFT+F10. The Command Console is displayed. The current path is %Systemroot%\System32.
  3. Type: cd drivers, and then press ENTER. The folder should be %Systemroot%\System32\Drivers.
  4. Type: rename cdudf.sys cdudf.old, and then press ENTER.
  5. To close the Command Console, type: exit. Then, press RESET to restart the computer.
  6. The in-place upgrade restarts and the CD-ROM is accessible to Windows 2000 Setup.
  7. After the in-place upgrade has completed and the computer is finished restarting, you may receive an error message: "At least one service failed to start". This error refers to the Cdudf.sys file being renamed.
  8. Open Windows Explorer and locate the %Systemroot%\System32\Drivers folder. Rename the Cdudf.old file back to Cdudf.sys, and then restart the computer.

MORE INFORMATION

If The CD-ROM still does not function after completing the preceding steps, refer to the following articles:

270008 Code 31 Messages Occur After Removing Adaptec Easy CD Creator 4.02c in Windows 2000

228852 Access to CD-ROM Lost When GUI-Mode Setup Starts

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:1/27/2006
Keywords:kbprb KB290790