Error Messages Are Displayed When You Perform an In-Place Upgrade (290790)
The information in this article applies to:
- Microsoft Windows 2000 Server
- Microsoft Windows 2000 Advanced Server
- Microsoft Windows 2000 Professional
This article was previously published under Q290790 SYMPTOMS
When you attempt to perform an in-place upgrade on Windows 2000 you may receive the following message at the start of the graphical user interface (GUI) Setup:
Please insert the compact disc labeled 'Windows 2000 (version) CD-ROM' into your CD-ROM Drive (x:), and then click OK.
When you click OK, you may receive the following message:
The file NT5inf.cat on the 'Windows 2000 (version) CD-ROM' is needed. Type the path where the file is located, and then click OK.
If you press CANCEL, you may receive the following error message:
Fatal Error: An error has been encountered that prevents Setup from continuing. Setup failed to install the product catalogs. This is a fatal error. The setup log files should contain more information. Click OK to view the Setup log file.
CAUSE
This behavior can occur if Adaptec DirectCD (any Windows 2000-compatible version) software has been run on the computer before you started the Windows 2000 in-place upgrade.
RESOLUTION
To work around this behavior, rename the Adaptec DirectCD driver, Cdudf.sys:
- Run Windows 2000 Setup and wait for the following message to be displayed:
Please insert the compact disc labeled 'Windows 2000 (version) CD-ROM' into your CD-ROM Drive (x:), and then click OK.
- Press SHIFT+F10. The Command Console is displayed. The current path is %Systemroot%\System32.
- Type: cd drivers, and then press ENTER. The folder should be %Systemroot%\System32\Drivers.
- Type: rename cdudf.sys cdudf.old, and then press ENTER.
- To close the Command Console, type: exit. Then, press RESET to restart the computer.
- The in-place upgrade restarts and the CD-ROM is accessible to Windows 2000 Setup.
- After the in-place upgrade has completed and the computer is finished restarting, you may receive an error message: "At least one service failed to start". This error refers to the Cdudf.sys file being renamed.
- Open Windows Explorer and locate the %Systemroot%\System32\Drivers folder. Rename the Cdudf.old file back to Cdudf.sys, and then restart the computer.
Modification Type: | Minor | Last Reviewed: | 1/27/2006 |
---|
Keywords: | kbprb KB290790 |
---|
|