Invalid Commerce Server 2000 Authentication Filter HTTP Responses (290785)



The information in this article applies to:

  • Microsoft Commerce Server 2000

This article was previously published under Q290785

SYMPTOMS

When Windows Authentication mode is enabled on your Commerce Server 2000 site, you may experience various problems during the authentication process. These errors may cause the following problems:
  • Some firewalls may silently drop invalid responses.
  • Internet Explorer may stop responding (hang) when you access the Commerce Server site over a proxy.

CAUSE

The Commerce Server Authentication filter can return the following incorrect responses if Windows Authentication Mode is enabled:
  • A response that is missing the Content-Length field from the HTTP response header.
  • The body of a redirect response that is not correctly terminated with a carriage return/line feed (CR/LF).

RESOLUTION

To resolve this problem, obtain the latest service pack for Commerce Server 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

297216 INFO: How to Obtain the Latest Commerce Server 2000 Service Pack


STATUS

Microsoft has confirmed that this is a problem in Microsoft Commerce Server 2000. This problem was first corrected in Commerce Server 2000 Service Pack 1.

Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE kbbug kbCommServ2000PreSP1fix kbCommServ2000SP1fix kbfix kbQFE KB290785