Cannot Automatically Log on Remotely to Terminal Server with Long User Name or Password (290706)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server

This article was previously published under Q290706

SYMPTOMS

When you are attempting to automatically log on to a Windows 2000-based computer that is running Terminal Services with an RDP client, the preconfigured user name and password do not allow you to log on.

You receive the following error message:
Logon Message:
The system could not log you on. Make sure your User name and domain are correct, then type your password again. Letters in passwords must be typed using the correct case. Make sure that Caps Lock is not accidentally on.

CAUSE

A remote automatic logon operation to a computer that is running Terminal Services with a long user name or password is not supported.

RESOLUTION

To resolve this problem, retype the user name or password immediately upon the automatic failure.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Terminal Services can be configured to allow users to pass all logon information via the client. Thus the RDP client can pass the username, password, and domain information, eliminating the need to type the information in at the Terminal Services prompt. However, even if Terminal Services is configured for this behavior, if the user's username or password is too long, Terminal Services will not properly process the logon.

Having the RDP client pass all logon information, including a long user name or password will fail. Terminal Services will respond with an error indicating the username or password is wrong. The user can then retype the correct information and continue. Windows 2000 Terminal Services does not support long user names or passwords remotely.


If security auditing is enabled on the Terminal Services, the following security event is logged:
Event Type:     Failure Audit
Event Source:   Security
Event Category: Logon/Logoff 
Event ID:       529
Date:           8/14/2000
Time:           05:13:00 AM
User:           NT AUTHORITY\SYSTEM
Computer:       TERMINALSERVER
Description:
Logon Failure:
        Reason:                 Unknown user name or bad password
        User Name:              enduser
        Domain:                 DOMAIN
        Logon Type:             2
        Logon Process:          User32  
        Authentication Package: Negotiate
        Workstation Name:       TERMINALSERVER
					

Modification Type:MinorLast Reviewed:1/27/2006
Keywords:kbbug kbenv kberrmsg KB290706