Cannot bring Exchange Server services online by using Windows 2000 Cluster Administrator (290651)
The information in this article applies to:
- Microsoft Exchange Server 5.5
- Microsoft Exchange Server 5.5 SP1
- Microsoft Exchange Server 5.5 SP2
- Microsoft Exchange Server 5.5 SP3
This article was previously published under Q290651 SYMPTOMS
When you try to bring an Exchange Server service online by using Windows 2000 Cluster Administrator (for example, System Attendant), the procedure may fail, and the service Start option may change from Manual to Disabled.
If you use the Services tool in Control Panel to change the Start option from Disabled to Manual again, and then try to bring the service online, the procedure fails again and the service Start option changes to Disabled again.
When this issue occurs, you cannot start the Exchange Server service because the Start option for the service is always Disabled, and the service status in Cluster Administrator is always displayed as Failed.
CAUSE
The issue may occur in either of the following scenarios:
- On the Generic Service Registry Replication page, the root registry key of a service is included. For example:
SYSTEM\CurrentControlSet\Services\MSExchangeSA - You manually changed the service Start option from Manual to Disabled when the specific service was online.
The Start option is saved in the root registry key of a specific service. The Start REG_DWORD value represents the Start option. When the specific service is online, and you change the Start option from Manual to Disabled, the Start option is saved in a Cluster generic service checkpoint file. After you take the service offline, the Start option in the checkpoint file remains as Disabled.
When the service is offline, even if you change the service Start option in Control Panel from Disabled to Manual, and then try to bring the service online by using Cluster Administrator, the Start option ( Disabled) is written from the checkpoint file to the registry. In this case, the service does not start.
RESOLUTION
To resolve this issue, follow the Exchange Server service registry replication registry key and do not change it. The default settings of core Exchange Server services do not include any service's root registry key. Use Cluster administrator to change the services' Registry Replication setting back to the default setting, and then change these services' Start options back to Manual. To change the services' Registry Replication setting back to the default setting, and to change these services' Start options back to Manual, use the following commands to remove the checkpoints and then to set the checkpoints to the correct registry keys. - Click Start, click Run, type cmd in the Open box, and then click OK.
- Type the following commands, and press ENTER after each command.
Note You must use the correct Exchange Server service that has to have the service Start option changed to Manual.- cluster res "Microsoft Exchange Message Transfer Agent" /removecheckpoints:SYSTEM\CurrentControlSet\Services\MSExchangeMTA
- cluster res "Microsoft Exchange Message Transfer Agent" /addcheckpoints:SYSTEM\CurrentControlSet\Services\MSExchangeMTA\Diagnostics
- cluster res "Microsoft Exchange Message Transfer Agent" /addcheckpoints:SYSTEM\CurrentControlSet\Services\MSExchangeMTA\Parameters
The registry key for the Exchange Server services are:
- System Attendant
- SYSTEM\CurrentControlSet\Services\MSExchangeSA\Diagnostics
- SYSTEM\CurrentControlSet\Services\MSExchangeSA\Parameters
- Directory Service
- SYSTEM\CurrentControlSet\Services\MSExchangeDS\Diagnostics
- SYSTEM\CurrentControlSet\Services\MSExchangeDS\Parameters
- Information Store
- SYSTEM\CurrentControlSet\Services\MSExchangeIS\Diagnostics
- SYSTEM\CurrentControlSet\Services\MSExchangeIS\Parameters
- Message Transfer Agent
- SYSTEM\CurrentControlSet\Services\MSExchangeMTA\Diagnostics
- SYSTEM\CurrentControlSet\Services\MSExchangeMTA\Parameters
Modification Type: | Major | Last Reviewed: | 6/24/2005 |
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Keywords: | kbprb KB290651 |
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