PRB: Error "Update <Username> Failed" When You Change User Password in BizDesk (290126)



The information in this article applies to:

  • Microsoft Commerce Server 2002
  • Microsoft Commerce Server 2000

This article was previously published under Q290126

SYMPTOMS

When you use BizDesk to change a user password in the Supplier AD solution site, you may receive the following error message:
Update <username> failed.
where <username> is the name of the user that you are trying to update.

When you click Details, you may see the following error message details:
Failure in parsing an URL command, hr: -1056948604, url:
Bad password encountered.

CAUSE

This error occurs if a policy is applied to the domain that restricts the account or password. For example, if a policy that restricts the password length to at least 10 characters is applied to the domain, and you try to change the user password to a password with nine characters, you receive the above-mentioned error message.

RESOLUTION

To resolve this problem, adhere to the domain policy when you change any password for a user in the Supplier AD solution site.

MORE INFORMATION

Steps to Reproduce Behavior

  1. Unpack the Supplier AD solution site on a computer that is a member of a domain.
  2. Change the domain policy to include a password policy for Minimum Password Length of 10 characters.
  3. In the Users module of the Supplier AD BizDesk, create a new user, and supply a password that meets the domain policy requirements.
  4. In the Users module of the Supplier AD BizDesk, try to change the password for the newly created user to nine characters. You receive the above-mentioned error message.

Modification Type:MajorLast Reviewed:10/22/2003
Keywords:kbprb KB290126