PRB: Error "Failed to Insert User" When You Add Users to Supplier AD Solution Site (290124)



The information in this article applies to:

  • Microsoft Commerce Server 2002
  • Microsoft Commerce Server 2000

This article was previously published under Q290124

SYMPTOMS

When you use BizDesk to try to add a user to the Supplier AD solution site, you may receive the following error message:
Failed to insert user.

After you click Details, you may see the following error message details:
Failure in parsing an URL command, hr: -2147016651, url:
PerformStorageAction(), Could not perform single instance
UPDATE operation (-2147016651)
The server is unwilling to process the request.
0000052D: SvcErr: DSID-031A0B56, problem 5003
(WILL_NOT_PERFORM), data 0

CAUSE

This error occurs if a policy is applied to the domain that restricts the account or password. For example, if a policy that restricts the password length to at least 10 characters is applied to the domain, and you try to create the user in BizDesk with a password of nine characters, you receive the above-mentioned error message.

RESOLUTION

To resolve this problem, adhere to the domain policy when you create any accounts in BizDesk for the Supplier AD solution site.

MORE INFORMATION

If you receive the above-mentioned error message, the user is created in Microsoft SQL Server but not in Active Directory. To successfully create the user in SQL Server and Active Directory, you must remove the user from the User List in BizDesk and then add the user again, following the password parameters that meet the domain policy.

Steps to Reproduce Behavior

  1. Unpack the Supplier AD solution site on a computer that is a member of a domain.
  2. Change the domain policy to include a password policy for Minimum Password Length of 10 characters.
  3. In the Users module of the Supplier AD BizDesk, create a new user with a password of nine characters. You receive the above-mentioned error message.

Modification Type:MajorLast Reviewed:10/22/2003
Keywords:kbprb KB290124