XGEN: Information Store Does Not Start or Exoledb Library Does Not Initialize (290105)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q290105

SYMPTOMS

When you attempt to start the Exchange 2000 information store process, the service control manager may report that the process stopped unexpectedly, and the information store may not start. If the information store does start, the following entry may be logged in an event log:
ID:101 (Information) Source:EXOLDDB Microsoft Exchange OLEDB has successfully shutdown.
That entry is followed by the following entry:
ID:9542 (Error) Source:ExchangeIS Initialization of external interface OLEDB failed; Error ecServerOOM.

CAUSE

This problem can occur if the Exoledb library does not initialize. When the Exoledb library initializes, it scans the HKEY_CLASSES_ROOT (HKCR) registry hive for content class information. If the Exoledb library finds a ProgID with a value that exceeds 259 characters, the Exoledb library cannot initialize. If the Exoledb library cannot initialize, a different problem in Exchange 2000 causes the information store to stop responding.

RESOLUTION

To resolve this problem, ensure that no ProgID under the HKEY_CLASSES_ROOT (HKCR) registry hive has a value that exceeds 259 characters. This value is used by Component Object Model (COM) as a "human readable ProgID." Although there is no defined limit for this field, anything longer than 259 characters is unusual and is probably a mistake.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbbug kbnofix KB290105