Error Message: An Interrupt Storm Has Caused the System to Hang (290101)



The information in this article applies to:

  • Microsoft Windows Advanced Server, Limited Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

This article was previously published under Q290101

SYMPTOMS

Your computer may hard hang (it may be completely frozen and unresponsive) and you may receive the following error message:
STOP: 0x000000F2 (0xFCA7C55C, 0x817B9B28, 0x817D2AA0, 0x00000002)

An interrupt storm has caused the system to hang.

Address FCA7C55C base at FCA72000, Datestamp 3A72BDEF - ACPI.sys

CAUSE

This problem can occur if any of the following behavior occurs:
  • A hardware device does not release its interrupt signal after being instructed to do so by the device driver.
  • A device driver ignores the interrupt signal that had been initiated from its hardware and the device driver does not instruct its hardware to release the interrupt signal.
  • A device driver claims the interrupt signal even though the interrupt signal had not been initiated from its hardware. (This behavior can only occur when multiple devices are sharing the same interrupt request (IRQ).
  • The Edge/Level Control Register (ELCR) is set incorrectly.
  • The ELCR interrupt-triggered devices share an IRQ (for example, a COM port and Peripheral Component Interconnect [PCI] small computer system interface [SCSI] controller).

RESOLUTION

To work around this problem, examine the fourth parameter in the error message. If the parameter is "0x00000001", the module pointed to is very likely the source of the problem. Either the driver is corrupt or missing; or the hardware is malfunctioning.

If the fourth parameter is "0x00000002", the module pointed to is the first interrupt service routine (ISR) in the chain. This module is not guaranteed to be the source of the problem.

NOTE: A computer that experiences this problem repeatedly may have devices that are on the same IRQ as the one for which the module is a driver. In the preceding scenario, trouble-shoot the same IRQ that the Advanced Configuration and Power Interface (ACPI) feature uses.

MORE INFORMATION

An interrupt storm is defined as a level-triggered interrupt signal that remains in the asserted state.

When a bugcheck occurs, it locates the module for which the ISR on the storming IRQ resides, and then displays the error message as listed in the Symptoms section of this article.

Technical information about the parameters in a bugcheck message:
  • Parameter 1: The address of the ISR (or the first ISR in the chain) that is connected to the storming interrupt vector.
  • Parameter 2: The ISR context value.
  • Parameter 3: The address of the interrupt object for the storming interrupt vector.
  • Parameter 4: The parameter is 0x1 if the ISR is not chained, or 0x2 if the ISR is chained.

Modification Type:MinorLast Reviewed:1/15/2006
Keywords:kberrmsg kbprb KB290101