XFOR: Notes Calendar Connector Stops Responding on Multiprocessor Computers (289795)



The information in this article applies to:

  • Microsoft Exchange Server 5.5

This article was previously published under Q289795

SYMPTOMS

The Microsoft Exchange Server Notes Calendar Connector (Calcon) may stop responding on dual-processor computers. The crash dumps show different stack traces and indicate heap corruption.

CAUSE

The problem can occur if a reference count check causes two threads to delete the same object at the same time.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Exchange Server 5.5 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:

Component: Notes Calendar Connector

File nameVersion
Calcon.exe5.5.2654.66
Excalcon.exe5.5.2654.66
Gwrouter.exe5.5.2654.66
Adminsvc.dll5.5.2654.66
Calsync.dll5.5.2654.66
Gwisecal.dll5.5.2654.66
Mapical.dll5.5.2654.66
Notescal.dll5.5.2654.66
Profscal.dll5.5.2654.66
Rtdsmcal.dll5.5.2654.66

NOTE: Due to file dependencies, this fix requires Microsoft Exchange Server version 5.5 Service Pack 4.

WORKAROUND

To work around this problem set the processor affinity on the calcon.exe process to use only one processor.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5.

Modification Type:MinorLast Reviewed:10/6/2005
Keywords:kbHotfixServer kbQFE kbbug kbExchange550preSP5fix kbfix kbQFE KB289795