PRB: Error "Predictor Service Is Not Installed" When You Open Segment Viewer (289687)



The information in this article applies to:

  • Microsoft Commerce Server 2002
  • Microsoft Commerce Server 2000

This article was previously published under Q289687

SYMPTOMS

When you open Segment Viewer in Business Desk, you may receive the following error message:
Predictor Service is not installed.
Details: Unable to connect to predictor service to list models. Perhaps it is not installed.

CAUSE

This problem can occur if Predictor Service is not installed properly. During Commerce Server 2000 installation, you received the following Commerce Server 2000 error messages:
A failure occurred in CA_DML_InstantiateResource() on D:\cs40\Private\cs40setup\ca_dll\dml.cpp:155. The error code is -2147352567, and the description is: Exception occurred"

-and-

A failure occurred in CA_PRED_InstantiateResource() on D:\cs40\Private\cs40setup\ca_dll\predictor.cpp:50. The error code is -2147352567, and the description is: Exception occurred"

RESOLUTION

To resolve this problem, re-install Predictor and Direct Mail components as follows:
  1. Uninstall Predictor and Direct Mail components. To do this, follow these steps:
    1. Run setup for Commerce Server 2000. Click Modify, and then click Custom Setup.
    2. Clear the Predictor Service and Direct Mailer Service check boxes.
    3. Finish the setup, and restart the system.
  2. Re-install Predictor and Direct Mail components. To do this, follow these steps:
    1. Run the setup again for Commerce Server 2000 components. Click Modify, and then click Custom Setup.
    2. Select the Predictor Service and Direct Mailer Service check boxes.
    3. Finish the setup.
  3. If you already have Commerce sites, you must add Predictor and Direct Mail resources at the application level. To do this, follow these steps:
    1. Open Commerce Server Manager Microsoft Management Console (MMC), and go to Site Resources for the specific site (for example, click Commerce Sites, click Retail, and then click Site Resources).
    2. Right-click Site Resources, point to New, and then click Add Resource.
    3. In the Add Resource From dialog box, click the PuP file.
    4. In the Commerce Server Site Packager Wizard, click to select the Predictor and Direct Mail resources.
    5. Finish the wizard.
    6. On the Start menu, click Run, and then type iisreset to reset Web and Commerce Services.

Modification Type:MajorLast Reviewed:10/22/2003
Keywords:kbprb KB289687