Display Color Matching Does Not Occur (289635)



The information in this article applies to:

  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98

This article was previously published under Q289635

SYMPTOMS

When you use Integrated Color Management (ICM) programs that perform color matching, the display color profile is not applied when bitmaps are displayed. Only the standard sRGB color transformation is performed, regardless of which profile has been set as the default display color profile.

Therefore, for example, Microsoft Internet Explorer may render some colors incorrectly on Web pages that implement ICM. It may be possible to verify that a particular Web page uses ICM by clicking Source on the View menu in Internet Explorer, and then searching for the following text:

DXImageTransform.Microsoft.ICMFilter

Note that this problem is not caused by, or limited to, Internet Explorer, or the indicated DirectX ICM filter. Other Web controls, as well as programs that are not HTEML-enabled, may also encounter this problem.

CAUSE

When you use color matching, the computer needs to determine what the output device is so that it can apply the correct color profile. There is a problem in doing this with bitmaps that results in always using the sRGB color transformation profile instead of using the correct default profile.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date        Time     Version    Size     File name
   --------------------------------------------------
   03/21/2001  08:44am  4.10.2002  345,680  GDI.EXE     Windows 98
   03/21/2001  08:49am  4.10.2002  138,752  GDI32.DLL   Windows 98
   03/20/2001  06:31pm  4.10.2225  345,680  GDI.EXE     Windows 98 Second Edition
   03/20/2001  06:38pm  4.10.2225  138,752  GDI32.DLL   Windows 98 Second Edition
   02/22/2001  12:39pm  4.90.3001  347,184  Gdi.exe     Windows Millennium
   02/22/2001  12:43pm  4.90.3001  156,672  Gdi32.dll   Windows Millennium
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about Windows Me hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

295413 General Information About Windows Millennium Edition Hotfixes

For additional information about Windows 98 and Windows 98 Second Edition hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

206071 General Information About Windows 98 and Windows 98 Second Edition Hotfixes


Modification Type:MinorLast Reviewed:10/18/2005
Keywords:kbHotfixServer kbQFE kbdisplay kbprb kbQFE KB289635