Stop 0xC2 BAD_POOL_CALLER" Error Message on Print Server (289265)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Server SP1

This article was previously published under Q289265

SYMPTOMS

A Windows 2000-based print server may randomly stop responding (hang) with a "Stop" error message on a blue screen. The stop code is 0xC2, and the first parameter is always 0x00000007. When this occurs, you may not be able to log on until you restart the computer several times and receive several "Stop" error messages. When you finally log on to the computer, the system event log on the server contains many printing-related error messages.

The following example shows the parameters of a sample Stop error message:
0xC2 (0x00000007,0x00000b86,0xa21fb2c0,0xa21fb2c8)

CAUSE

This problem may occur if you try to free a pool that was already freed.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version             Size  File name
   --------------------------------------------------------
   19-Feb-2001  23:27  5.0.2195.3080    222,480  Gdi32.dll
   19-Feb-2001  23:27  5.0.2195.3055    379,152  User32.dll
   19-Feb-2001  23:20  5.0.2195.3274  1,641,392  Win32k.sys
   19-Feb-2001  23:27  5.0.2195.3071    243,472  Winsrv.dll

STATUS

Microsoft has confirmed that this is a problem in Microsoft Windows 2000 Service Pack 1.

Modification Type:MinorLast Reviewed:10/7/2005
Keywords:kbHotfixServer kbQFE kbbug kbshell kbWin2000sp3fix KB289265