FIX: Audit Failures in Security Event Log When You Call Component Services Objects (289118)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Professional SP1

This article was previously published under Q289118

SYMPTOMS

When a Component Services object is called, the Security Event Log displays an audit failure in the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSDTC\MTxOCI

CAUSE

This problem occurs because the Microsoft Distributed Transaction Coordinator (MS DTC) service tries to open the registry with Full access instead of Read-only access.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

This fix is included with the fixes that are described in the following Microsoft Knowledge Base article:

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.

Modification Type:MajorLast Reviewed:9/19/2006
Keywords:kbbug kbDTC kbfix kbWin2000PreSP3Fix kbWin2000sp3fix KB289118