PRB: SubmitSync() Call Fails To Use Configured Retries (288860)
The information in this article applies to:
- Microsoft BizTalk Server 2000
This article was previously published under Q288860 SYMPTOMS
When you use the SubmitSync() method of the IInterchange interface, you may notice that even though you have the channel configured to retry document delivery, if an error occurs, the document is immediately placed into the Suspended Queue.
CAUSE
A synchronous interchange bypasses all queues and executes all the components required by the messaging port on the calling thread. When one of these components fails and returns an error, this error is returned to the SubmitSync() call.
RESOLUTION
This behavior is by design.
Modification Type: | Major | Last Reviewed: | 11/7/2003 |
---|
Keywords: | kbprb KB288860 |
---|
|