XADM: The MTA May Sporadically Return Mail with the Transfer-Failure Reason Code (288848)



The information in this article applies to:

  • Microsoft Exchange Server 5.5 SP4
  • Microsoft Exchange Server 5.5
  • Microsoft Exchange Server 5.5 SP1
  • Microsoft Exchange Server 5.5 SP2
  • Microsoft Exchange Server 5.5 SP3

This article was previously published under Q288848

SYMPTOMS

Mail that is sent with attachments may be sent back to the sender, and a non-delivery report (NDR) may be generated. In some cases, the recipients still receive the mail. The following events may be logged in the Application event log:
Event Type: Warning
Event Source: MSExchangeMTA
Event Category: X.400 Service
Event ID: 290
Description:
A non-delivery report (reason code transfer-failure and diagnostic code Omit any diagnostic code) is being generated for message C=US;A= ;P=ORG;L=ServerName-#########Z-#####. It was originally destined for DN:/o=ORG/ou=CORP/cn=RECIPIENTS/cn=USER§ (recipient number 1), and was to be redirected to . [MTA DISP:RESULT 18 136] (12)
Event Type: Information
Event Source: MSExchangeMTA
Event Category: X.400 Service
Event ID: 270
Description:
A permanent error has occurred with Entity /O=ORG/OU=CORP/CN=CONFIGURATION/CN=SERVERS/CN=ServerName/CN=MICROSOFT PRIVATE MDB. Entity is a Message Object is a Normal Priority Message. Object: #######. Message ID: C=US;A= ;P=ORG;L=ServerName-########z-##### Content length:####, .....
Event Type: Information
Event Source: MSExchangeIS Private
Event Category: Transport Delivering
Event ID: 2025
Description:
The delivery of a message failed due to error 0000050A. A non-delivery report is being sent to the message's originator.

CAUSE

This problem can occur because of the virus scanning application programming interface (API) mode scanner for the information store. When a message with an attachment is sent to multiple users on the same server, the message transfer agent (MTA) submits the message multiple times. The store "sees" these submissions as the same message because of single instance storage; if the message has not been scanned yet, the message issues an error back to the MTA, which interprets the error as a communications error. The MTA then issues the NDR.

RESOLUTION

To resolve this problem, follow these steps:
  1. Apply the post-Exchange Server 5.5 SP4 Information Store fix roll-up. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

    282533 Exchange Server 5.5 post-Service Pack 4 information store fixes available

  2. Shut down the Exchange Server computer, and then restart it.

WORKAROUND

To work around this problem, change the antivirus software from virus scanning API mode to Messaging Application Programming Interface (MAPI) mode.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5.

MORE INFORMATION

After you apply this fix, the information store releases the attachment and passes it to MTA to deliver outgoing mail. In some cases, the attachments are not scanned completely by the virus scan before they are released to the MTA. This may result in infected attachments being sent through outgoing mail. This is by design. The Exchange AV API version 1.0 guarantees virus cleanup for incoming mail but only commercially reasonable efforts for outgoing mail. Customers who apply this fix should make sure that they have the Antivirus product on all of the Messaging servers.

Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kbbug kberrmsg kbExchange550preSP5fix kbfix kbQFE KB288848