You receive a "Device not ready" error message when you try to restore a database to a different file path in Exchange 2000 Server (288558)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • Microsoft Exchange 2000 Enterprise Server

This article was previously published under Q288558

SYMPTOMS

If you try to restore a database to a different file path in a scenario where the log files did not have a clean shutdown, you may receive the following error message:
The device is not ready.
JET_errDiskIO
For example, you may receive this error message if the original database file path was D:\pub.edb, and the new server references drive D as a CD drive.

CAUSE

This problem occurs because, when the log files do not have a clean shutdown, JET (ESE98) tries to build a full restore path based from the database and ignores the prompt that it is restoring to another destination. JET cannot continue after it receives the error that the destination is unavailable, such as a message that the CD drive is not ready.

RESOLUTION

To resolve this problem, obtain the latest service pack for Microsoft Exchange 2000 Server. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

301378 XGEN: How to obtain the latest Exchange 2000 Server service pack


WORKAROUND

To work around this problem, put a CD in the CD drive. This action makes the CD drive ready, and JET (ESE98) can then continue and can complete the restore successfully.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

This problem was first corrected in Microsoft Exchange 2000 Server Service Pack 1.

Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kberrmsg kbbug kbExchange2000preSP1fix kbpending KB288558 kbAudITPRO