SQL error when you try to access SharePoint Team Web site (288536)



The information in this article applies to:

  • SharePoint Team Services from Microsoft

This article was previously published under Q288536
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you use a Web browser to try to access a SharePoint team Web site, you receive the following error message:
SQL Server Error
The SQL Server might not be started.
If this problem persists, please contact your administrator.
Troubleshoot issues with Microsoft SharePoint.

CAUSE

The SQL Server user account password was changed but was not updated in the registry.

-or-

The SQL database may have Restrict Access turned on. Restrict Access may cause contention when accessing resources in the SQL database. This in turn can cause the error message in the "Symptom" section to be generated.

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this problem, reset the SQL Server user account password (default = SA) by using SQL Enterprise Manager. To do this, follow these steps:
  1. Click Start, point to Programs, and then click SQL Server.

    Click Enterprise Manager.
  2. Expand the Microsoft SQL Server selection.
  3. Expand the SQL Server Group selection.
  4. Expand the Machine Name selection.
  5. Expand the Security folder.
  6. Double-click Logins.
  7. In the right pane, right-click the user name (for example, SA).
  8. Click Properties.
  9. Reset the password.
Verify that the password matches the registry key.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, click Run, and then type Regedit in the Open box.
  2. Expand the following key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\Secure\/LM/W3SVC/#:] # = Virtual server #

  3. Verify that the databasePassword is the same as the password that you reset earlier in this procedure. If it is not, double-click databasePassword, and then type the same password that you typed in the SQL Enterprise Manager.

    Note Also verify that the DSN is pointing to the correct SQL database.
To resolve the database contention problem, you have to clear the Restrict Access setting. To do this, follow these steps:
  1. Start SQL Enterprise Manager.
  2. Locate the Content Database that you used for your particular Team Site.
  3. Right-click the database, and then click Properties.
  4. Click the Options tab, click Restrict Access to clear the setting, and then click OK.
After you complete these steps, the Team Site should be able to successfully connect to this database and perform operations as directed by the Web site.

MORE INFORMATION

This behavior applies to both SQL Server 7.0 and SQL Server 2000 installed locally or remotely.

Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbprb KB288536