Server randomly drops all connections, system log records multiple instances of Event ID 2000 (288301)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition

This article was previously published under Q288301

SYMPTOMS

At random intervals, the server may drop all connections, and no new connections can be established. Administrators can log on to the local computer, but Server Manager is not displayed correctly. Multiple instances of Event ID 2000 may be recorded in the System event log with this error message:

Event ID: 2000
Source: Srv
Description: The server's call to a system service failed unexpectedly.

0000: 00040000 00540001 00000000 c00007d0
0010: 00000000 c0000054 00000000 00000000
0020: 00000000 00000000 05930bd3
After you install Windows Server 2003 SP1 and Microsoft Security Update MS05-027, you may notice a decrease in performance. You may also notice connectivity issues. Multiple instances of Event ID 2000 may be recorded in the System event log when a Windows client tries to access a network share on the file server: Event Type: Error
Event Source: Srv
Event Category: None
Event ID: 2000
Description: The server's call to a system service failed unexpectedly. Data Words: 0000: 00040000 00540001 00000000 c00007d0 0010: 00000000 c0000054 00000000 00000000 0020: 00000000 00000000 022a0342 Note The error code c0000054 translates to STATUS_FILE_LOCK_CONFLICT. The second part of the dumpdata 0342 translates to SRV_SVC_MDL_COMPLETE. This indicates the server servcie is actually failing in a "complete MDL write" request.

CAUSE

This behavior can occur when you have an early version of the Cheyenne Open File Agent program installed.

This behavior may also occur because of an outdated version of a third-party kernel-mode file system filter driver (RxFsFltr.sys) of VERITAS Storage Replicator may this problem because. The RxFsFltr.sys file may keep part of the file locked.

RESOLUTION

To resolve this behavior, obtain and install the latest version of Open File Agent. Alternatively, to resolve this behavior, contact Veritas and obtain and install the latest version of the VERITAS Storage Replicator drivers.

WORKAROUND

To work around this behavior, remove the Cheyenne Open File Agent program. You can also work around this behavior by removing the VERITAS Storage Replicator program.

MORE INFORMATION

For more information about the latest version of Open File Manager, contact St. Bernard Software.

For information about how to contact St. Bernard Software, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z


Modification Type:MajorLast Reviewed:1/19/2006
Keywords:kbprb KB288301