Computer Hangs Randomly with NTFS and Cache Manager (288179)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0

This article was previously published under Q288179

SYMPTOMS

A Windows NT 4.0-based server may stop responding (hang) randomly during heavy file input/output (I/O).

CAUSE

There is a problem with Ntfs.sys and Cache Manager that can cause the computer to hang. The problem occurs because NTFS owns a resource that Cache Manager use to write data, but the Cache Manager thread runs at a higher priority.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date         Version        Size     File name     Platform
   -----------------------------------------------------------
   07-Feb-2002  4.0.1381.7130  957,248  Ntkrnlmp.exe  I386
   07-Feb-2002  4.0.1381.7130  936,896  Ntoskrnl.exe  I386
				
NOTE: Because of file dependencies, this hotfix requires Microsoft Windows NT 4.0 Service Pack 6a.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE kbWinNT400nospFix KB288179