Error Message About LPT1 Access Denied Appears When You Try to Print to Local Printer (288092)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0

This article was previously published under Q288092

SYMPTOMS

IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry



When you attempt to print to a local printer attached to the LPT1 port, you may not be able to do so, and you may receive the following error message:

"Error writing to LPT1, Access Denied"

CAUSE

This behavior can occur when you have previously installed and then uninstalled the Hewlett-Packard JetAdmin program, and there are still some registry entries related to it.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

  1. Start Registry Editor (Regedt32.exe).
  2. Locate the Hewlett-Packard JetDirect Port Monitor key under the following key in the registry:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Monitors

  3. On the Edit menu, click Delete, and then click OK.
  4. Quit Registry Editor.
  5. Restart the computer.
  6. Print to the local printer attached to the LPT1 port.

Modification Type:MajorLast Reviewed:6/11/2002
Keywords:kbprb KB288092