Rich Text Format Does Not Work After the Exchange Management Agent Is Run (287718)



The information in this article applies to:

  • Microsoft Metadirectory Services 2.1
  • Microsoft Metadirectory Services 2.2

This article was previously published under Q287718

SYMPTOMS

After you ran the Exchange Lightweight Directory Access Protocol (LDAP) Management Agent (MA), you cannot receive e-mail messages in Rich Text Format. Before you ran the MA, you could use this format.

CAUSE

This problem can occur because the Rich Text Format has been reconfigured in the MA templates. By default, the template configuration is:
$v_MapiRecipient="0"
				
If you changed this setting to "1", the following configuration would cause a problem:
$v_MapiRecipient to "1"
				

RESOLUTION

To resolve this problem, change the Foreign Entries export templates which affects Custom Recipients on Exchange. The same process can be applied to the Control Connected Directory templates for local Exchange users. To set the variable:
  1. On the Actions menu, click Design MA for the MA under consideration.
  2. Under Design MA, click the Connected Directory Foreign Entries tab.
  3. Click Foreign Entries Output Construction Template.
  4. Under Foreign Entries, locate the area of the script where the $v_MapiRecipient variable is set. Depending on the number of modifications made to the logic of the script, there may be more than one area that needs to be changed.
  5. Set the variable to "TRUE". For example: $v_MapiRecipient="TRUE"

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

The default script contains the $v_MapiRecipient=0 statement which can give the impression that the variable should be set to either "0" or "1". In fact, the correct values are "TRUE" and "FALSE".

Modification Type:MinorLast Reviewed:1/25/2006
Keywords:kbbug kbenv kbfix KB287718