Secondary site installation stops responding (287717)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0

This article was previously published under Q287717

SYMPTOMS

When you try to install a secondary site from a parent site, the installation may stop responding (hang) for various reasons and it may take a long time for the parent site to report the unsuccessful installation. If the secondary site is purged from the Systems Management Server (SMS) Administrator console of the parent site before the problem is reported, jobs that are trying to install the secondary site may continue uninterrupted.

CAUSE

This issue may occur for various reasons, including, but not limited to, network issues and disk space issues.

WORKAROUND

To work around this issue, manually stop the secondary site installation.

Note You must remove any old information from the installation.

To perform the manual cleanup:
  1. For each secondary site, delete the secondary site address from Site Settings\Addresses in the Administrator console.
  2. For each secondary site, run the preinst /delsite command from a command prompt on the SMS parent site to purge the failed secondary site from the database. The PREINST tool is located in the Support directory on the SMS CD-ROM, and you must run it from the site server. Use preinst /? to receive the exact syntax for this utility. For additional information about how to use the PREINST utility, click the following article number to view the article in the Microsoft Knowledge Base:

    212978 Description of Preinst.exe for Systems Management Server 2.0

  3. For each secondary site, run the preinst /deljob command to have the tool remove any pending or active jobs to those sites.
  4. Verify that the secondary sites are completely removed. To make sure that the computer is clean of the unsuccessful SMS installation:
    1. Verify that no SMS or Winmgmt services are running on the computer, including the SMSBootstrap service. If they are, stop them, and then set the startup type to manual.
    2. Verify that the following SMS registry keys were removed:

      HKEY_LOCAL_MACHINE/Software/Microsoft/SMS
      HKEY_LOCAL_MACHINE/Software/Microsoft/NAL HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/SMS_Executive
      HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/SMS_NT_Logon_Discovery_Agent
      HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/SMS_Site_Config_Manager
      HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/SMS_Bootstrap
      HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/CLISVC

      Note Also delete HKEY_LOCAL_MACHINE/Software/Microsoft/WBEM and HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/WMI
      ONLY if the server is running Microsoft Windows NT 4.0 or earlier.
    3. Verify that the following directories were removed, where X is the SMS installation drive:

      X:\SMS
      X:\SMSBootstrap.log
      C:\SMSSetup.log
      %Winnt%\MS\SMS

      Note You may need to restart the computer to remove some of these directories.
    4. View the client access points (CAPs) and distribution points (DPs) for the site, and then verify that the CAP_xxx SMS_PKG shares were deleted and that the directories were removed (where xxx is the sitecode of the secondary site).
    5. If you used Logon Installation or Discovery during the installation, make sure that the specific sitecode directory is removed from the SMSLOGON\Sites directory of the primary domain controller in the domain.
    6. With User Manager, make sure that any site-specific accounts were deleted. At a minimum, this includes the SMSClient_xxx and SMSServer_xxx accounts (where xxx is the sitecode of the secondary site.) After you complete this, you can complete the secondary site installation by using the same sitecode.

Modification Type:MinorLast Reviewed:6/14/2005
Keywords:kbConfig kbHMan kbprb kbServer kbsetup kbsmsAdmin KB287717