XFOR: Mail Sits in the Exchange 2000 Outbound Queue (287667)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • Microsoft Exchange Server 5.5

This article was previously published under Q287667

SYMPTOMS

When Exchange 2000 is located behind Microsoft Proxy Server 2.0, outbound messages may intermittently experience the following symptoms:
  • Outbound mail is not flowing consistently.
  • It cannot be sent to specific domain names.
  • Messages may be duplicated in the outbound queue.
When you use the Domain Name Server (DNS) of the Internet Service Provider (ISP), all the preceding problems disappear.

CAUSE

The WinSock proxy client is installed on the server that is hosting DNS. This causes the system to use the DNS server entries on the proxy server, and consequently, the Exchange 2000 server may display the behavior described in the "Symptoms" section.

RESOLUTION

To resolve this issue:
  1. Remove the proxy client from the DNS servers.
  2. Confirm that the Servers tab on the properties of a particular DNS zone allows any listed system to act as a secondary DNS server and receive zone updates.
  3. Confirm that DNS starts to forward as it is supposed to.

MORE INFORMATION

You may be able to telnet through the proxy server, but still experience occasional stoppage when sending outbound mail through the proxy server.

Changing the order of the DNS IP addresses does not help, and applying the proxy server hotfix described in the following Microsoft Knowledge Base article may not help:

262373 Proxy Stops Listening for Server Proxy If AcceptEx() Does Not Succeed with Error Code 64

Adding the external DNS IP to the Forward Lookup Zones property page of the Name server does not help either.

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

287044 With Winsock Proxy Client Installed on Proxy Server, DNS Host Name Resolution Does Not Work


Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbprb KB287667