Desktop Does Not Load for Any User (287654)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server

This article was previously published under Q287654

SYMPTOMS

When any user, including the administrator, attempts to log on at the console of a server running Terminal Services, only the blue background is displayed. The mouse is active, but not the keyboard.

Also, users are unable to make a Terminal Services connection to this server. They will receive the following error message:
The client could not connect to the Terminal server. The server may be too busy. Please try connecting later.

Viewing the System Event log of the computer remotely will reveal the following event
Event ID: 34 Source: TermService Description: {Access Denied} A process has requested access to an object, but has not been granted those access rights.

CAUSE

This can be caused if the Terminal Services service is configured to log on with an account other than the Local System account.

RESOLUTION

To resolve this issue, follow these steps:
  1. Start the Computer Management Microsoft Management Console (MMC) from a remote computer, and then connect to this computer.
  2. Click to expand Services And Applications, and then click Services.
  3. Configure Terminal Services to log on using the Local System account, and then restart the server.NOTE: Windows 2000 Terminal Services should only run under the context of the local System account.

MORE INFORMATION

The following hotfix for Windows 2000 Server and Windows 2000 Advanced Server may resolve the symptoms described in this article.

NOTE: The hotfix described in the following article does not resolve the issue of the Terminal Services service running under an account other than the system account. It addresses a different issue with the same symptoms. Click the article number below to view the article in the Microsoft Knowledge Base:

291041 Tsadmin.exe May Hang After Connecting to Multiple Servers


Modification Type:MinorLast Reviewed:1/27/2006
Keywords:kbenv kberrmsg kbprb kbui KB287654